summaryrefslogtreecommitdiff
path: root/games-simulation/corsix-th
diff options
context:
space:
mode:
Diffstat (limited to 'games-simulation/corsix-th')
-rw-r--r--games-simulation/corsix-th/Manifest2
-rw-r--r--games-simulation/corsix-th/corsix-th-0.65.1.ebuild82
2 files changed, 84 insertions, 0 deletions
diff --git a/games-simulation/corsix-th/Manifest b/games-simulation/corsix-th/Manifest
index 0fa1e3c2b8b3..4f15b98db28b 100644
--- a/games-simulation/corsix-th/Manifest
+++ b/games-simulation/corsix-th/Manifest
@@ -1,4 +1,6 @@
AUX corsix-th-0.64-cmake_lua_detection.patch 288 BLAKE2B 90673498871c16f48c752c5581dfec0a290966ef0ec79c977b69575b26a22843829679a7c0225caabe2b570b9b6a38e025115f3a2cf0597b0dad9dc78f01f36d SHA512 52dc61c7aa8c170da225801f2eb06140e9dc28c4d55853eac99b573475a21fb03b945de676898719927abd517b34ecce2aa5c4998ac6e6fcc673cf2aaf7cdb9e
DIST corsix-th-0.64.tar.gz 4062048 BLAKE2B 2b807a5c712a19cac80bae613065dd8c9e1219573a3c288c1433b6fa857c3a93632e9c51ba126a70626b4044d469ca1ebc815257f291fa9f86ea94491aae35fe SHA512 c02d07ae4fb9a1ce008f32c4b9ea12a949316feddca4e2a29e860e0d88efdfa0440d372b00b9d3eda5e5c3ca739085510ebe8650790d06a7e91255b7d0990e6c
+DIST corsix-th-0.65.1.tar.gz 4163922 BLAKE2B c1d9255e41521876716b377579642ed46b9fc54823816dc431f7b56ffa532af7091ae0b1e291bb1c4fb74165ca07786e0991a990c90bc3a13e234ba31c6fa706 SHA512 b7e964c22517b94cb1dafb0529368c87a2e58cf1f784062b9f2f72749ba69523b63d4f846ebd582c71cf5ca7e7c437a34717ca3877ad3737139ba2fd6a316577
EBUILD corsix-th-0.64-r100.ebuild 1952 BLAKE2B 02649e3c0f2de55cb02e036e330080f36aa07dd4e170ac18ea391adbaf041e3cac9d02abee22541442ec5c4dc0649f881b558c18f4af4f488b4525a823682486 SHA512 8e0708ae6c2fc61a59c3951a556e9ce38ae24c24903cc282e4712f47f5f44892e34c02ff52134be5136c6e5809cfc0bd9796ae550826bdda69ae683f7480d22f
+EBUILD corsix-th-0.65.1.ebuild 1923 BLAKE2B a7a1da03327d47ae76baca6f6db3d31595d4797209e9fcd63456e391071bf6ce930ac5b920addc0110825345cd24415133f5cb4bc33a82644ef648d0037bb834 SHA512 a16e7f70f62a92ffcca948d6c6c74a33b2d8e3b8b3cd38de95daf378dccb16852e8012a2a607f9eef9ca94cd00ec4f60f3607b8b63c691118eaec52d447beba6
MISC metadata.xml 716 BLAKE2B 16fe66f9f3fce58b6b17df3906fdcf4e9b7a9a49be872ba69cd5deeb47bffca495ff3a8b8c89fc71cbe8b3960954a462aff8c10c6afd34c18acef95931c382f8 SHA512 643ef59451c07fd3e61b22fb9891cc2478dff78c1e2a50ed455b15bf1c01e49d384af177c687e48b2bd6590278ac121458a94760a25bdc064ce309ff5ab3b868
diff --git a/games-simulation/corsix-th/corsix-th-0.65.1.ebuild b/games-simulation/corsix-th/corsix-th-0.65.1.ebuild
new file mode 100644
index 000000000000..96f236c3d3d4
--- /dev/null
+++ b/games-simulation/corsix-th/corsix-th-0.65.1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..4} )
+
+inherit cmake lua-single xdg
+
+MY_PN="CorsixTH"
+
+DESCRIPTION="Open source clone of Theme Hospital"
+HOMEPAGE="https://corsixth.com"
+SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="doc +midi +sound +truetype +videos"
+
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND="${LUA_DEPS}
+ $(lua_gen_cond_dep '
+ >=dev-lua/luafilesystem-1.5[${LUA_USEDEP}]
+ >=dev-lua/lpeg-0.9[${LUA_USEDEP}]
+ >=dev-lua/luasocket-3.0_rc1-r4[${LUA_USEDEP}]
+ ')
+ media-libs/libsdl2[opengl,video]
+ sound? ( media-libs/sdl2-mixer[midi?] )
+ truetype? ( >=media-libs/freetype-2.5.3:2 )
+ videos? ( >=media-video/ffmpeg-2.2.3:0= )
+"
+
+DEPEND="${RDEPEND}"
+
+# Technically, build-time generation of documentation could use any version
+# of Lua (or to be precise: if in src_configure cmake has been told to use
+# LuaJIT documentation generation looks for LuaJIT, otherwise any
+# dev-lang/lua slot will do; see the first few lines of the bundled file
+# CMake/GenerateDoc.cmake for details) - but since dev-lang/lua conflicts
+# with the other slots of same, try to keep the deptree sane until we get
+# rid of unslotted Lua.
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen[dot]
+ ${LUA_DEPS}
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.64-cmake_lua_detection.patch
+)
+
+src_prepare() {
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DLUA_VERSION=$(lua_get_version)
+ -DWITH_AUDIO=$(usex sound)
+ -DWITH_FREETYPE2=$(usex truetype)
+ -DWITH_MOVIES=$(usex videos)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ use doc && cmake_src_compile doc
+}
+
+src_install() {
+ cmake_src_install
+ dodoc {changelog,CONTRIBUTING}.txt
+
+ docinto html
+ use doc && dodoc -r "${BUILD_DIR}"/doc/*
+}