summaryrefslogtreecommitdiff
path: root/games-simulation/corsix-th/corsix-th-0.67.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-simulation/corsix-th/corsix-th-0.67.ebuild')
-rw-r--r--games-simulation/corsix-th/corsix-th-0.67.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/games-simulation/corsix-th/corsix-th-0.67.ebuild b/games-simulation/corsix-th/corsix-th-0.67.ebuild
index fb20bf9d939b..abeaae5f4a0c 100644
--- a/games-simulation/corsix-th/corsix-th-0.67.ebuild
+++ b/games-simulation/corsix-th/corsix-th-0.67.ebuild
@@ -39,23 +39,23 @@ RDEPEND="${LUA_DEPS}
DEPEND="${RDEPEND}"
-# Technically, build-time generation of documentation could use any version
-# of Lua (or to be precise: if in src_configure cmake has been told to use
-# LuaJIT documentation generation looks for LuaJIT, otherwise any
-# dev-lang/lua slot will do; see the first few lines of the bundled file
-# CMake/GenerateDoc.cmake for details) - but since dev-lang/lua conflicts
-# with the other slots of same, try to keep the deptree sane until we get
-# rid of unslotted Lua.
+# Although the docs could potentially be built with nearly any Lua version,
+# we need to ensure the necessary Lua modules are installed, so pin to the
+# same single version as runtime.
BDEPEND="
virtual/pkgconfig
doc? (
app-doc/doxygen[dot]
${LUA_DEPS}
+ $(lua_gen_cond_dep '
+ >=dev-lua/luafilesystem-1.5[${LUA_USEDEP}]
+ >=dev-lua/lpeg-0.9[${LUA_USEDEP}]
+ ')
)
"
PATCHES=(
- "${FILESDIR}"/${PN}-0.66-cmake_lua_detection.patch
+ "${FILESDIR}"/${PN}-0.67-cmake_lua_detection.patch
)
src_configure() {