summaryrefslogtreecommitdiff
path: root/games-roguelike/tome
diff options
context:
space:
mode:
Diffstat (limited to 'games-roguelike/tome')
-rw-r--r--games-roguelike/tome/Manifest6
-rw-r--r--games-roguelike/tome/files/2.3.5-gentoo-paths.patch31
-rw-r--r--games-roguelike/tome/files/tome-2.3.5-format.patch88
-rw-r--r--games-roguelike/tome/files/tome-2.3.5-noX.patch11
-rw-r--r--games-roguelike/tome/metadata.xml8
-rw-r--r--games-roguelike/tome/tome-2.3.5.ebuild124
6 files changed, 268 insertions, 0 deletions
diff --git a/games-roguelike/tome/Manifest b/games-roguelike/tome/Manifest
new file mode 100644
index 000000000000..64535c326611
--- /dev/null
+++ b/games-roguelike/tome/Manifest
@@ -0,0 +1,6 @@
+AUX 2.3.5-gentoo-paths.patch 1172 BLAKE2B d51e277eac8d270815a8b48a18bd943489036643d53b80d4adab147a7510e4b41f1f9ff1062327f7b441c2aea9e3d6509a1dffa69b60dca32fe36f73a639f8c9 SHA512 1d3f053abcbfee4f2fb1acc2911927b4a51881b0ce50da72d4d617207411b9cdba42cf70324c47535e9e560ee8878f3d0f51d4471dcc2bcfaffb136700c6fd0f
+AUX tome-2.3.5-format.patch 2925 BLAKE2B f9d186937649bfc3d409a73cf6a8f067784628374de2c5da656e2f871ba71c3f6edd1837bec79972ecea985f3002374f9edd8184aff3d1c101de25e20cd901a9 SHA512 e8e245e6374ac63effc8f3e1341357f137cd8b4fb378a464e2bd3692d50e5cbd54b7b42b8605346c2d617e1dbb95e42bc9f79a36cc378d07881c73136d603ddb
+AUX tome-2.3.5-noX.patch 453 BLAKE2B 4ec72b20f50593b871990d7b65aec1cd51fe5c25c5de29350b7cf1a77063e13d393962efbadc1380aec97ec1889c645faff54470def7c5200be5050c5c7a87c0 SHA512 9c3fe5a8a9fa0e1e1b0e1ffb4ca8a089eda401a04bc6fe14aba8866090cd96ad13f5fac501ae18ce937f13a94439c8c1ebaa80c7fc07d1c4da9c3c8fa80f67c2
+DIST tome-235-src.tar.bz2 2951227 BLAKE2B 7a9a6c608873062f9d6deae38c7e39244ca25d2bbb553d338014078c86b9decc36869c2f39f875425f9c3bb26784d3e460a225c5dabd197437781488f3e15d74 SHA512 f456aa91d18397297c213fa67dd14a4d29e024525be99f83b22cbe42f4d426b57fe6115a7124e3ec34de8f351117de525eab996ba7a2a230119e43639c4c9205
+EBUILD tome-2.3.5.ebuild 3632 BLAKE2B 934ccc63c844f796f064bdf7bed82514c5e849dc0d858ab4d39fd22a11a1ab942a0acfe2f4cc9ae77249bf2a0b86c92591fbf0e09f0aa0c9184f93d91eca5a7a SHA512 bd0335cf3229759ff8e8570e6e3ca84414956d3057aa2c4c134d665d6a5cc9b7945ec6eba588e16075a50428d03833be5489edb5758483e1c6343ba2da0ca100
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-roguelike/tome/files/2.3.5-gentoo-paths.patch b/games-roguelike/tome/files/2.3.5-gentoo-paths.patch
new file mode 100644
index 000000000000..d171a1cf540f
--- /dev/null
+++ b/games-roguelike/tome/files/2.3.5-gentoo-paths.patch
@@ -0,0 +1,31 @@
+diff -rU 1 tome-225-src.orig/src/files.c tome-225-src/src/files.c
+--- tome-225-src.orig/src/files.c 2004-01-14 11:17:02.423263360 -0500
++++ tome-225-src/src/files.c 2004-01-14 11:17:50.074019344 -0500
+@@ -5670,3 +5670,3 @@
+ /* Build the filename */
+- path_build(buf, 1024, ANGBAND_DIR_APEX, "scores.raw");
++ sprintf(buf, "GENTOO_DIR/tome-scores.raw");
+
+@@ -5748,3 +5748,3 @@
+ /* Build the filename */
+- path_build(buf, 1024, ANGBAND_DIR_APEX, "scores.raw");
++ sprintf(buf, "GENTOO_DIR/tome-scores.raw");
+
+@@ -5846,3 +5846,3 @@
+ /* Build the filename */
+- path_build(buf, 1024, ANGBAND_DIR_APEX, "scores.raw");
++ sprintf(buf, "GENTOO_DIR/tome-scores.raw");
+
+@@ -6296,3 +6296,3 @@
+ /* Build the filename */
+- path_build(buf, 1024, ANGBAND_DIR_APEX, "scores.raw");
++ sprintf(buf, "GENTOO_DIR/tome-scores.raw");
+
+diff -rU 1 tome-225-src.orig/src/init2.c tome-225-src/src/init2.c
+--- tome-225-src.orig/src/init2.c 2004-01-14 11:17:02.473255760 -0500
++++ tome-225-src/src/init2.c 2004-01-14 11:17:58.286770816 -0500
+@@ -6686,3 +6686,3 @@
+ /* Build the filename */
+- path_build(buf, 1024, ANGBAND_DIR_APEX, "scores.raw");
++ sprintf(buf, "GENTOO_DIR/tome-scores.raw");
+
diff --git a/games-roguelike/tome/files/tome-2.3.5-format.patch b/games-roguelike/tome/files/tome-2.3.5-format.patch
new file mode 100644
index 000000000000..f3ce1cc96faf
--- /dev/null
+++ b/games-roguelike/tome/files/tome-2.3.5-format.patch
@@ -0,0 +1,88 @@
+--- dungeon.c.old 2016-02-07 20:12:39.258150130 +0100
++++ dungeon.c 2016-02-07 20:12:58.239805610 +0100
+@@ -1489,7 +1489,7 @@
+ {
+ char buf[20];
+
+- sprintf(buf, get_day(bst(YEAR, turn) + START_YEAR));
++ sprintf(buf, "%s", get_day(bst(YEAR, turn) + START_YEAR));
+ cmsg_format(TERM_L_GREEN,
+ "Today it is %s of the %s year of the third age.",
+ get_month_name(bst(DAY, turn), wizard, FALSE), buf);
+--- files.c.old 2016-02-07 20:15:07.736451417 +0100
++++ files.c 2016-02-07 20:15:27.595089867 +0100
+@@ -4856,7 +4856,7 @@
+
+ /* Terminate */
+ tmp[k] = '\0';
+- sprintf(player_base, tmp);
++ sprintf(player_base, "%s", tmp);
+
+ /* Require a "base" name */
+ if (!player_base[0]) strcpy(player_base, "PLAYER");
+--- lua_bind.c.old 2016-02-07 20:09:29.071592178 +0100
++++ lua_bind.c 2016-02-07 20:10:48.094164373 +0100
+@@ -490,7 +490,7 @@
+ /* Files */
+ void lua_print_hook(cptr str)
+ {
+- fprintf(hook_file, str);
++ fprintf(hook_file, "%s", str);
+ }
+
+
+--- plots.c.old 2016-02-07 20:11:35.389308152 +0100
++++ plots.c 2016-02-07 20:12:19.247513152 +0100
+@@ -93,7 +93,7 @@
+ {
+ MAKE(new, hooks_chain);
+ new->hook = hook;
+- sprintf(new->name, name);
++ sprintf(new->name, "%s", name);
+ #ifdef DEBUG_HOOK
+ if (wizard) cmsg_format(TERM_VIOLET, "HOOK ADD: %s", name);
+ if (take_notes) add_note(format("HOOK ADD: %s", name), 'D');
+--- spells1.c.old 2016-02-07 20:15:47.277731397 +0100
++++ spells1.c 2016-02-07 20:16:03.373438169 +0100
+@@ -7312,7 +7312,7 @@
+
+ if (who == -2)
+ {
+- sprintf(killer, t_name + t_info[cave[p_ptr->py][p_ptr->px].t_idx].name);
++ sprintf(killer, "%s", t_name + t_info[cave[p_ptr->py][p_ptr->px].t_idx].name);
+ }
+
+ /* Analyze the damage */
+--- squeltch.c.old 2016-02-07 20:13:11.872558078 +0100
++++ squeltch.c 2016-02-07 20:13:42.707997918 +0100
+@@ -399,7 +399,7 @@
+
+ if (!max) continue;
+
+- sprintf(name, string_exec_lua(format("return __rules[%d].table.args.name", sel)));
++ sprintf(name, "%s", string_exec_lua(format("return __rules[%d].table.args.name", sel)));
+ if (input_box("New name?", hgt / 2, wid / 2, name, 15))
+ {
+ exec_lua(format("auto_aux:rename_rule(%d, '%s')", sel, name));
+--- util.c.old 2016-02-07 20:14:22.786269296 +0100
++++ util.c 2016-02-07 20:16:44.227693551 +0100
+@@ -4468,7 +4468,7 @@
+ {
+ char buf2[20];
+
+- sprintf(buf2, get_day(day + 1));
++ sprintf(buf2, "%s", get_day(day + 1));
+ if (full) sprintf(buf, "%s (%s day)", month_name[i], buf2);
+ else sprintf(buf, "%s", month_name[i]);
+ break;
+@@ -4479,8 +4479,8 @@
+ char buf2[20];
+ char buf3[20];
+
+- sprintf(buf2, get_day(day + 1 - month_day[i]));
+- sprintf(buf3, get_day(day + 1));
++ sprintf(buf2, "%s", get_day(day + 1 - month_day[i]));
++ sprintf(buf3, "%s", get_day(day + 1));
+
+ if (full) sprintf(buf, "%s day of %s (%s day)", buf2, month_name[i], buf3);
+ else if (compact) sprintf(buf, "%s day of %s", buf2, month_name[i]);
diff --git a/games-roguelike/tome/files/tome-2.3.5-noX.patch b/games-roguelike/tome/files/tome-2.3.5-noX.patch
new file mode 100644
index 000000000000..5c5982fe730d
--- /dev/null
+++ b/games-roguelike/tome/files/tome-2.3.5-noX.patch
@@ -0,0 +1,11 @@
+--- makefile.old 2012-05-28 14:02:44.787705444 +0200
++++ makefile 2012-05-28 14:03:44.520524011 +0200
+@@ -458,7 +458,7 @@
+ $(CC) $(PROFILELDFLAGS) $(LDFLAGS) -o $@ $(OBJS) $(LIBS)
+
+ $(TOLUA): $(TOLUAOBJS) lua/tolua.c lua/tolualua.c
+- $(CC) $(CFLAGS) $(PROFILELDFLAGS) $(LDFLAGS) -o $@ $(TOLUAOBJS) lua/tolua.c lua/tolualua.c $(LIBS)
++ $(CC) $(CFLAGS) $(PROFILELDFLAGS) $(LDFLAGS) -o $@ $(TOLUAOBJS) lua/tolua.c lua/tolualua.c
+
+ #
+ # An install rule.
diff --git a/games-roguelike/tome/metadata.xml b/games-roguelike/tome/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-roguelike/tome/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-roguelike/tome/tome-2.3.5.ebuild b/games-roguelike/tome/tome-2.3.5.ebuild
new file mode 100644
index 000000000000..cdb3c58fefd5
--- /dev/null
+++ b/games-roguelike/tome/tome-2.3.5.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils games
+
+MY_PV=${PV//./}
+DESCRIPTION="save the world from Morgoth and battle evil (or become evil ;])"
+HOMEPAGE="http://t-o-m-e.net/"
+SRC_URI="http://t-o-m-e.net/dl/src/tome-${MY_PV}-src.tar.bz2"
+
+LICENSE="Moria"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X Xaw3d gtk sdl"
+
+RDEPEND=">=sys-libs/ncurses-5:0
+ X? ( x11-libs/libX11 )
+ Xaw3d? ( x11-libs/libXaw )
+ sdl? (
+ media-libs/sdl-ttf
+ media-libs/sdl-image
+ media-libs/libsdl )
+ gtk? ( >=x11-libs/gtk+-2.12.8:2 ) "
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ x11-misc/makedepend"
+
+S=${WORKDIR}/tome-${MY_PV}-src/src
+
+src_prepare() {
+ mv makefile.std makefile
+ epatch "${FILESDIR}/${PV}-gentoo-paths.patch" \
+ "${FILESDIR}"/${P}-format.patch \
+ "${FILESDIR}"/${P}-noX.patch
+ sed -i -e '/^CC =/d' makefile || die
+ sed -i -e "s:xx:x:" ../lib/edit/p_info.txt || die
+ sed -i -e "s:GENTOO_DIR:${GAMES_STATEDIR}:" files.c init2.c || die
+
+ find .. -name .cvsignore -exec rm -f \{\} +
+ find ../lib/edit -type f -exec chmod a-x \{\} +
+}
+
+src_compile() {
+ local GENTOO_INCLUDES="" GENTOO_DEFINES="-DUSE_GCU " GENTOO_LIBS="$(pkg-config ncurses --libs)"
+ if use sdl || use X || use gtk || use Xaw3d; then
+ GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_EGO_GRAPHICS -DUSE_TRANSPARENCY \
+ -DSUPPORT_GAMMA"
+ fi
+ if use sdl || use X || use Xaw3d; then
+ GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_PRECISE_CMOVIE -DUSE_UNIXSOCK "
+ fi
+ if use sdl; then
+ GENTOO_INCLUDES="${GENTOO_INCLUDES} $(sdl-config --cflags)"
+ GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_SDL "
+ GENTOO_LIBS="${GENTOO_LIBS} $(sdl-config --libs) -lSDL_image -lSDL_ttf"
+ fi
+ if use X; then
+ GENTOO_INCLUDES="${GENTOO_INCLUDES} -I/usr/X11R6/include "
+ GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_X11 "
+ GENTOO_LIBS="${GENTOO_LIBS} -L/usr/X11R6/lib -lX11 "
+ fi
+ if use Xaw3d; then
+ GENTOO_INCLUDES="${GENTOO_INCLUDES} -I/usr/X11R6/include "
+ GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_XAW "
+ GENTOO_LIBS="${GENTOO_LIBS} -L/usr/X11R6/lib -lXaw -lXmu -lXt -lX11 "
+ fi
+ if use gtk; then
+ GENTOO_INCLUDES="${GENTOO_INCLUDES} $(pkg-config gtk+-2.0 --cflags)"
+ GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_GTK2 "
+ GENTOO_LIBS="${GENTOO_LIBS} $(pkg-config gtk+-2.0 --libs) "
+ GTK_SRC_FILE="main-gtk2.c"
+ GTK_OBJ_FILE="main-gtk2.o"
+ else
+ GTK_SRC_FILE=""
+ GTK_OBJ_FILE=""
+ fi
+ if use amd64; then
+ GENTOO_DEFINES="${GENTOO_DEFINES} -DLUA_NUM_TYPE=int "
+ fi
+ GENTOO_INCLUDES="${GENTOO_INCLUDES} -Ilua -I."
+ GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_LUA"
+ emake -j1 \
+ INCLUDES="${GENTOO_INCLUDES}" \
+ DEFINES="${GENTOO_DEFINES}" \
+ depend
+ emake ./tolua
+ emake \
+ COPTS="${CFLAGS}" \
+ INCLUDES="${GENTOO_INCLUDES}" \
+ DEFINES="${GENTOO_DEFINES}" \
+ LIBS="${GENTOO_LIBS} -lm" \
+ BINDIR="${GAMES_BINDIR}" \
+ LIBDIR="${GAMES_DATADIR}/${PN}" \
+ GTK_SRC_FILE="${GTK_SRC_FILE}" \
+ GTK_OBJ_FILE="${GTK_OBJ_FILE}"
+}
+
+src_install() {
+ emake -j1 \
+ DESTDIR="${D}" \
+ OWNER="${GAMES_USER}" \
+ BINDIR="${GAMES_BINDIR}" \
+ LIBDIR="${GAMES_DATADIR}/${PN}" install
+ cd ..
+ dodoc *.txt
+
+ dodir "${GAMES_STATEDIR}"
+ touch "${D}/${GAMES_STATEDIR}/${PN}-scores.raw"
+ prepgamesdirs
+ fperms g+w "${GAMES_STATEDIR}/${PN}-scores.raw"
+ #FIXME: something has to be done about this.
+ fperms g+w "${GAMES_DATADIR}/${PN}/data"
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ ewarn "ToME ${PV} is not save-game compatible with 2.3.0 and previous versions."
+ echo
+ ewarn "If you have older save files and you wish to continue those games,"
+ ewarn "you'll need to remerge the version of ToME with which you started"
+ ewarn "those save-games."
+}