summaryrefslogtreecommitdiff
path: root/games-roguelike/stone-soup/stone-soup-0.31.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-roguelike/stone-soup/stone-soup-0.31.0.ebuild')
-rw-r--r--games-roguelike/stone-soup/stone-soup-0.31.0.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/games-roguelike/stone-soup/stone-soup-0.31.0.ebuild b/games-roguelike/stone-soup/stone-soup-0.31.0.ebuild
index c44ae6304971..aabb2224fe3e 100644
--- a/games-roguelike/stone-soup/stone-soup-0.31.0.ebuild
+++ b/games-roguelike/stone-soup/stone-soup-0.31.0.ebuild
@@ -22,7 +22,6 @@ inherit desktop python-any-r1 lua-single xdg-utils toolchain-funcs
DESCRIPTION="Role-playing roguelike game of exploration and treasure-hunting in dungeons"
HOMEPAGE="https://crawl.develz.org"
-SLOT="0.31"
# Leave empty string if not a _pre release
COMMITSHA=""
@@ -40,23 +39,26 @@ else
"
MY_P="crawl-${COMMITSHA}/crawl-ref"
fi
+# MY_SLOT to satisfy pkgcheck variable order checking
+MY_SLOT="0.31"
SRC_URI="
${SRC_URI}
- https://dev.gentoo.org/~stasibear/distfiles/${PN}.png -> ${PN}-${SLOT}.png
- https://dev.gentoo.org/~stasibear/distfiles/${PN}.svg -> ${PN}-${SLOT}.svg
+ https://dev.gentoo.org/~stasibear/distfiles/${PN}.png -> ${PN}-${MY_SLOT}.png
+ https://dev.gentoo.org/~stasibear/distfiles/${PN}.svg -> ${PN}-${MY_SLOT}.svg
"
+S=${WORKDIR}/${MY_P}/source
# 3-clause BSD: mt19937ar.cc, MSVC/stdint.h
# 2-clause BSD: all contributions by Steve Noonan and Jesse Luehrs
# Public Domain|CC0: most of tiles
# MIT: json.cc/json.h, some .js files in webserver/static/scripts/contrib/
LICENSE="GPL-2 BSD BSD-2 public-domain CC0-1.0 MIT"
-KEYWORDS="~amd64 ~x86"
+SLOT="${MY_SLOT}"
+KEYWORDS="amd64 x86"
IUSE="advpng debug ncurses sound test +tiles"
RESTRICT="!test? ( test )"
REQUIRED_USE="${LUA_REQUIRED_USE}"
-S=${WORKDIR}/${MY_P}/source
RDEPEND="
${LUA_DEPS}
dev-db/sqlite:3