summaryrefslogtreecommitdiff
path: root/games-roguelike/stone-soup/stone-soup-0.30.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-roguelike/stone-soup/stone-soup-0.30.1.ebuild')
-rw-r--r--games-roguelike/stone-soup/stone-soup-0.30.1.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/games-roguelike/stone-soup/stone-soup-0.30.1.ebuild b/games-roguelike/stone-soup/stone-soup-0.30.1.ebuild
index ef68cd84dd1f..92908ca4accc 100644
--- a/games-roguelike/stone-soup/stone-soup-0.30.1.ebuild
+++ b/games-roguelike/stone-soup/stone-soup-0.30.1.ebuild
@@ -22,7 +22,6 @@ inherit desktop python-any-r1 lua-single xdg-utils toolchain-funcs
DESCRIPTION="Role-playing roguelike game of exploration and treasure-hunting in dungeons"
HOMEPAGE="https://crawl.develz.org"
-SLOT="0.30"
# Leave empty string if not a _pre release
COMMITSHA=""
@@ -40,23 +39,26 @@ else
"
MY_P="crawl-${COMMITSHA}/crawl-ref"
fi
+# MY_SLOT to satisfy pkgcheck variable order checking
+MY_SLOT="0.30"
SRC_URI="
${SRC_URI}
- https://dev.gentoo.org/~stasibear/distfiles/${PN}.png -> ${PN}-${SLOT}.png
- https://dev.gentoo.org/~stasibear/distfiles/${PN}.svg -> ${PN}-${SLOT}.svg
+ https://dev.gentoo.org/~stasibear/distfiles/${PN}.png -> ${PN}-${MY_SLOT}.png
+ https://dev.gentoo.org/~stasibear/distfiles/${PN}.svg -> ${PN}-${MY_SLOT}.svg
"
+S=${WORKDIR}/${MY_P}/source
# 3-clause BSD: mt19937ar.cc, MSVC/stdint.h
# 2-clause BSD: all contributions by Steve Noonan and Jesse Luehrs
# Public Domain|CC0: most of tiles
# MIT: json.cc/json.h, some .js files in webserver/static/scripts/contrib/
LICENSE="GPL-2 BSD BSD-2 public-domain CC0-1.0 MIT"
+SLOT="${MY_SLOT}"
KEYWORDS="amd64 x86"
IUSE="advpng debug ncurses sound test +tiles"
RESTRICT="!test? ( test )"
REQUIRED_USE="${LUA_REQUIRED_USE}"
-S=${WORKDIR}/${MY_P}/source
RDEPEND="
${LUA_DEPS}
dev-db/sqlite:3