summaryrefslogtreecommitdiff
path: root/games-roguelike/dwarf-fortress/files/Makefile.native
diff options
context:
space:
mode:
Diffstat (limited to 'games-roguelike/dwarf-fortress/files/Makefile.native')
-rw-r--r--games-roguelike/dwarf-fortress/files/Makefile.native9
1 files changed, 8 insertions, 1 deletions
diff --git a/games-roguelike/dwarf-fortress/files/Makefile.native b/games-roguelike/dwarf-fortress/files/Makefile.native
index 85383e5e2f1d..d22fb03f4694 100644
--- a/games-roguelike/dwarf-fortress/files/Makefile.native
+++ b/games-roguelike/dwarf-fortress/files/Makefile.native
@@ -1,6 +1,8 @@
# Copyright 2014-2016 Alex Xu (Hello71)
# Distributed under the terms of the GNU General Public License v2
+HAVE_GTK ?= 1
+
SRCS := g_src/basics.cpp g_src/command_line.cpp g_src/enabler.cpp \
g_src/files.cpp g_src/find_files_posix.cpp g_src/graphics.cpp \
g_src/init.cpp g_src/interface.cpp g_src/keybindings.cpp \
@@ -11,7 +13,12 @@ SRCS := g_src/basics.cpp g_src/command_line.cpp g_src/enabler.cpp \
OBJS := $(SRCS:.cpp=.o)
BLIBS := ncursesw openal sndfile
-LIBS := glew glu gtk+-2.0 sdl SDL_image SDL_ttf zlib
+
+LIBS := glew glu sdl SDL_image SDL_ttf zlib
+ifeq ($(HAVE_GTK),1)
+LIBS += gtk+-2.0
+endif
+
CXXFLAGS ?= -O2 -pipe -Wall -Wextra
CXXFLAGS += $(shell $(PKG_CONFIG) --cflags $(BLIBS) $(LIBS)) -Dunix -Dlinux -fPIC -std=c++11 -D_GLIBCXX_USE_CXX11_ABI=0
LDLIBS := $(shell $(PKG_CONFIG) --libs $(LIBS))