summaryrefslogtreecommitdiff
path: root/games-puzzle
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/Manifest.gzbin17931 -> 17760 bytes
-rw-r--r--games-puzzle/larry/Manifest4
-rw-r--r--games-puzzle/larry/files/larry-wrapper7
-rw-r--r--games-puzzle/larry/larry-1-r1.ebuild64
-rw-r--r--games-puzzle/larry/metadata.xml8
-rw-r--r--games-puzzle/triptych-demo/triptych-demo-0.ebuild49
-rw-r--r--games-puzzle/triptych/Manifest (renamed from games-puzzle/triptych-demo/Manifest)2
-rw-r--r--games-puzzle/triptych/metadata.xml (renamed from games-puzzle/triptych-demo/metadata.xml)0
-rw-r--r--games-puzzle/triptych/triptych-1.16.ebuild63
9 files changed, 64 insertions, 133 deletions
diff --git a/games-puzzle/Manifest.gz b/games-puzzle/Manifest.gz
index cea20a2e6733..33fe9d1c09b1 100644
--- a/games-puzzle/Manifest.gz
+++ b/games-puzzle/Manifest.gz
Binary files differ
diff --git a/games-puzzle/larry/Manifest b/games-puzzle/larry/Manifest
deleted file mode 100644
index 8e3f731ae436..000000000000
--- a/games-puzzle/larry/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX larry-wrapper 131 BLAKE2B df07aeee362510f0876f7ce403974e45f0e4dcb1f1b96df190808c9bd501172e56ca00b3a4c5b279c56f18cb259f39df0d87f1e68e389a74babc574d52437425 SHA512 d7260aea5f34994355453d40cde2a2e71610517abdc2a6b76a2f78ed8cc0a0ad06a8eed4e5a1419ae7daf36f6fbcb0252d999f6f0625ca3b9ae7a234e43afa0c
-DIST LarryReloadedLinux.tar.gz 767543995 SHA256 8fe697796e8a62f52105490da6768c35a3d5f76a5aafe02a9d10fb387186e703 SHA512 81ad52ba562eb890d2f001c3e4174222b183064103da3c4f2ddcb4cbf3ad432892b35aeb6b4e253ffc972431f6c673c149bb4a80d742a05c20bec803feaaa23a WHIRLPOOL 9d75e5b28091a12e064247ea71cc6d3ddb5132c974b65f7cd2ddcd167e3a24bbf30024b0d7777b4f7770c2199e28e5959cc033b7a052fbb14ea422c43cbfb142
-EBUILD larry-1-r1.ebuild 1327 BLAKE2B b5aaf27cead98e5b868d2dd60f7e39c5d4d17dd0fe4894ba9644355ddbca018293da21f9924837c1257063a8dc1d9fcb98a86cb4cf54aacfc0679d5aa047c954 SHA512 6567765a4504c642f04330a3cd66b71eae8374ef0effe5fa7ab314d0f4e0147148c720a6261428cfa9ee093eaf5483a842efd9b8098cd841410ab22452dc76bf
-MISC metadata.xml 253 BLAKE2B 443ca9c8d4f6801169382e87a0ecd1385c56e65229209e7200f9d313ef380e92ae8d7dc3c38e5989a4166289f22607a20b1e13bb960fff6b3d9f78629d8ab020 SHA512 61c4689cbc649d84a00be211b7b5b98dd03e1d3f813eff370df549f2998cd4343f391c18b57cf20e4a8f4dd2311e3bfa04eb60f356f2bbac78f0b68f5091f254
diff --git a/games-puzzle/larry/files/larry-wrapper b/games-puzzle/larry/files/larry-wrapper
deleted file mode 100644
index 717be43fbd10..000000000000
--- a/games-puzzle/larry/files/larry-wrapper
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/sh
-
-# https://forums.replaygamesinc.com/viewtopic.php?f=28&t=1141
-export LC_ALL=C
-
-cd "@GAMES_DIR@"
-exec ./Larry-Linux "$@"
diff --git a/games-puzzle/larry/larry-1-r1.ebuild b/games-puzzle/larry/larry-1-r1.ebuild
deleted file mode 100644
index ce80803c9680..000000000000
--- a/games-puzzle/larry/larry-1-r1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils check-reqs gnome2-utils games
-
-DESCRIPTION="Leisure Suit Larry Reloaded"
-HOMEPAGE="https://www.replaygamesinc.com"
-SRC_URI="LarryReloadedLinux.tar.gz"
-
-LICENSE="all-rights-reserved"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-RESTRICT="bindist fetch splitdebug"
-
-QA_PREBUILT="${GAMES_PREFIX_OPT#/}/${PN}/Larry-Linux
- ${GAMES_PREFIX_OPT#/}/${PN}/Larry-Linux_Data/Mono/x86/libmono.so"
-CHECKREQS_DISK_VAR="4500M"
-CHECKREQS_DISK_USR="4500M"
-
-S=${WORKDIR}
-
-pkg_nofetch() {
- einfo "Please buy & download ${SRC_URI} from:"
- einfo " ${HOMEPAGE}"
- einfo "and move it to ${DISTDIR}"
- einfo
-}
-
-src_prepare() {
- sed \
- -e "s#@GAMES_DIR@#${GAMES_PREFIX_OPT}/${PN}#" \
- "${FILESDIR}"/${PN}-wrapper > "${S}"/larry || die
-}
-
-src_install() {
- newicon -s 128 Larry/Larry-Linux_Data/Resources/UnityPlayer.png ${PN}.png
- make_desktop_entry ${PN}
-
- dogamesbin larry
- # move it, over 4gb
- dodir "${GAMES_PREFIX_OPT}"/${PN}
- mv Larry/* "${ED%/}/${GAMES_PREFIX_OPT}"/${PN}/ || die
-
- fperms +x "${GAMES_PREFIX_OPT}"/${PN}/Larry-Linux
-
- prepgamesdirs
-}
-
-pkg_preinst() {
- games_pkg_preinst
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- games_pkg_postinst
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}
diff --git a/games-puzzle/larry/metadata.xml b/games-puzzle/larry/metadata.xml
deleted file mode 100644
index 26079e608bed..000000000000
--- a/games-puzzle/larry/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>games@gentoo.org</email>
- <name>Gentoo Games Project</name>
- </maintainer>
-</pkgmetadata>
diff --git a/games-puzzle/triptych-demo/triptych-demo-0.ebuild b/games-puzzle/triptych-demo/triptych-demo-0.ebuild
deleted file mode 100644
index fcf9d969a487..000000000000
--- a/games-puzzle/triptych-demo/triptych-demo-0.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils games
-
-DESCRIPTION="fast-paced tetris-like puzzler"
-HOMEPAGE="http://www.chroniclogic.com/triptych.htm"
-SRC_URI="http://s159260531.onlinehome.us/demos/triptych.tar.gz"
-
-LICENSE="all-rights-reserved"
-SLOT="0"
-KEYWORDS="-* ~x86"
-IUSE=""
-RESTRICT="mirror bindist strip"
-
-DEPEND="x11-libs/libXext
- media-libs/libsdl[opengl,sound,video]
- virtual/opengl"
-RDEPEND=${DEPEND}
-
-QA_PREBUILT="${GAMES_PREFIX_OPT}/${PN}/triptych ${GAMES_PREFIX_OPT}/${PN}/setup"
-
-S=${WORKDIR}/triptych
-
-src_install() {
- local dir=${GAMES_PREFIX_OPT}/${PN}
- dodir "${dir}"
-
- cp -pPR * "${D}"/${dir}/ || die
- games_make_wrapper triptych ./triptych "${dir}"
-
- prepgamesdirs
-}
-
-pkg_postinst() {
- games_pkg_postinst
- # Fix perms on status files #74217
- local f
- for f in triptych.{clr,cnt,scr} ; do
- f="${ROOT}/${GAMES_PREFIX_OPT}/${PN}/${f}"
- if [[ ! -e ${f} ]] ; then
- touch "${f}" \
- && chmod 660 "${f}" \
- && chown ${GAMES_USER}:${GAMES_GROUP} "${f}" \
- || die
- fi
- done
-}
diff --git a/games-puzzle/triptych-demo/Manifest b/games-puzzle/triptych/Manifest
index bdf88e197013..18a53864776b 100644
--- a/games-puzzle/triptych-demo/Manifest
+++ b/games-puzzle/triptych/Manifest
@@ -1,3 +1,3 @@
DIST triptych.tar.gz 1748316 BLAKE2B 0d66265df27f61ddee1e1777a1e749d3a8bbcebf0e2bfe64a054febb48def865b68ab59d9c25804ed725bb11d24af2bbd712cc2de88a7259db26aa6d7c3c8d1f SHA512 614de78c9f90dd2145ff3dfa6f7a799a069c5add80bc8b0494a752346a163ab0eff7b707292b815adbffa34e4fec446035cfb65df4dd6cf284f270bb732b6daa
-EBUILD triptych-demo-0.ebuild 1086 BLAKE2B f0ca3b7e3e8cdf459533419224dc15e1106be8fe180adcc04ecf905c71f2e78fbe236519fe23b3929716f9b90b2900b98276e1fc83348f0074921b10992352af SHA512 b66e1813a177c3268da4f60f392d22ee5048ec947e7035597a717655cd41b098bb08182345c749608a3c42d67680757ae53ec3a67b100d5aea59575a2e1bf602
+EBUILD triptych-1.16.ebuild 1294 BLAKE2B 6125e2c24fe8a02c6eec1b40e9cf47a240e56c4b3cc57a55a4662bd8a490149db24f2f1cfbe4fef79ca31ffb99a437422af87ff8e52faf2e411f319b8918187b SHA512 9d5bae71e7550254ede4d05d1d6bee2ba17e7126b4b7c87d9a6f5a0a4db517b01c8cfff7ce5fa117a9f28fd583f8f07b0d9d744d01027cee914e2fba158fec7e
MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-puzzle/triptych-demo/metadata.xml b/games-puzzle/triptych/metadata.xml
index 78274e0fa550..78274e0fa550 100644
--- a/games-puzzle/triptych-demo/metadata.xml
+++ b/games-puzzle/triptych/metadata.xml
diff --git a/games-puzzle/triptych/triptych-1.16.ebuild b/games-puzzle/triptych/triptych-1.16.ebuild
new file mode 100644
index 000000000000..e2257e17ad3f
--- /dev/null
+++ b/games-puzzle/triptych/triptych-1.16.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop eutils user
+
+DESCRIPTION="Fast-paced Tetris-like puzzler"
+HOMEPAGE="http://www.chroniclogic.com/triptych.htm"
+SRC_URI="http://www.chroniclogic.com/demos/${PN}.tar.gz"
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="bindist mirror strip"
+
+RDEPEND=">=media-libs/libsdl-1.2[abi_x86_32,opengl,sound,video]
+ virtual/opengl[abi_x86_32]
+ x11-libs/libX11[abi_x86_32]
+ x11-libs/libXext[abi_x86_32]"
+
+QA_PREBUILT="opt/${PN}/${PN}
+ opt/${PN}/setup"
+
+S="${WORKDIR}/${PN}"
+
+DIR="/opt/${PN}"
+WRITABLE=( "${EROOT}${DIR}"/{hwconfig.cfg,${PN}.{clr,cnt,scr}} )
+
+pkg_setup() {
+ enewgroup gamestat 36
+}
+
+src_prepare() {
+ default
+ rm -v *.dll || die
+}
+
+src_install() {
+ local EXES=( ${PN} setup )
+
+ insinto "${DIR}"
+ doins -r .
+
+ exeinto "${DIR}"
+ doexe "${EXES[@]}"
+
+ fowners root:gamestat "${EXES[@]/#/${DIR}/}" || die
+ fperms g+s "${EXES[@]/#/${DIR}/}" || die
+
+ make_wrapper ${PN} ./${PN} "${DIR}"
+ make_wrapper ${PN}-setup ./setup "${DIR}"
+}
+
+pkg_postinst() {
+ touch "${WRITABLE[@]}" || die
+ chown root:gamestat "${WRITABLE[@]}" || die
+ chmod 0664 "${WRITABLE[@]}" || die
+}
+
+pkg_prerm() {
+ [[ -z ${REPLACED_BY_VERSION} ]] &&
+ rm -v "${WRITABLE[@]}"
+}