summaryrefslogtreecommitdiff
path: root/games-puzzle/world-of-goo
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/world-of-goo')
-rw-r--r--games-puzzle/world-of-goo/Manifest2
-rw-r--r--games-puzzle/world-of-goo/world-of-goo-1.41-r2.ebuild (renamed from games-puzzle/world-of-goo/world-of-goo-1.41-r1.ebuild)27
2 files changed, 14 insertions, 15 deletions
diff --git a/games-puzzle/world-of-goo/Manifest b/games-puzzle/world-of-goo/Manifest
index 193d153ab3ea..9e80b891e04d 100644
--- a/games-puzzle/world-of-goo/Manifest
+++ b/games-puzzle/world-of-goo/Manifest
@@ -1,3 +1,3 @@
DIST WorldOfGooSetup.1.41.tar.gz 66428181 BLAKE2B 476c05f0b3f78fa952728b9f7b5b95942e7f3e57dde4842144ccaa28c9ad2d2c264b1a2277ba5a1f3edf25cb812c72a0380b0d26b2bc99dd9a77116badcf5477 SHA512 278dfb983cf9cf4de87f13d94f5e75b3830af07523e2ddc7a443d5afb6fead130ed50440357554986b5b0d99c17651f77ae11298f51f9f1072ebd40287cad396
-EBUILD world-of-goo-1.41-r1.ebuild 1435 BLAKE2B b292ac0388cdc845c13775448f093c9f15339f12017dbc364d21f9c6c65eb4588f3fdc5a85116a2051c2a934edec28f5632756f2369cbc195005181aece5887b SHA512 56212dbeac141cc805bae061f6f62e43b7d3770bbe4a9a53c73bb80b8f43b06b193680bc3b5a1e576b7574d5e64852db38a69e1080269e7dea09b003189f4f86
+EBUILD world-of-goo-1.41-r2.ebuild 1472 BLAKE2B 4464e577d888be78e0fdabc8a9026724ad3f249bb2b90b7e4d9369e9b84a051be4725b6d488f4cf880b56f44681e5115f64e7dcc7b56782bf1e9e1044d0b2877 SHA512 ee612026cb24862f5ebba0e69a5089dcbabc5a4dae3f9efdf04b65188e708cb06e779c91c67a3accdf1a9a3c36b75547ea7f491dbb9d02724a6c84171f725fe7
MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-puzzle/world-of-goo/world-of-goo-1.41-r1.ebuild b/games-puzzle/world-of-goo/world-of-goo-1.41-r2.ebuild
index b941fe96f8d3..51f7f12ff569 100644
--- a/games-puzzle/world-of-goo/world-of-goo-1.41-r1.ebuild
+++ b/games-puzzle/world-of-goo/world-of-goo-1.41-r2.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils games
+EAPI=6
+
+inherit desktop eutils # eutils for make_wrapper()
DESCRIPTION="A puzzle game with a strong emphasis on physics"
HOMEPAGE="http://2dboy.com/"
@@ -18,8 +19,7 @@ fi
LICENSE="2dboy-EULA"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-RESTRICT="fetch strip"
+RESTRICT="fetch bindist strip"
RDEPEND="media-libs/libsdl[alsa,sound,opengl,video]
media-libs/sdl-mixer[vorbis]
@@ -27,10 +27,9 @@ RDEPEND="media-libs/libsdl[alsa,sound,opengl,video]
virtual/opengl
virtual/glu
>=sys-devel/gcc-3.4"
-DEPEND=""
-S=${WORKDIR}/${MY_PN}
-dir=${GAMES_PREFIX_OPT}/${PN}
+S="${WORKDIR}/${MY_PN}"
+dir="/opt/${PN}"
QA_PREBUILT="${dir:1}/${MY_PN%Demo}.bin32
${dir:1}/${MY_PN%Demo}.bin64"
@@ -38,9 +37,10 @@ QA_PREBUILT="${dir:1}/${MY_PN%Demo}.bin32
pkg_nofetch() {
if [[ ${PN} == *-demo ]] ; then
elog "To download the demo, visit http://worldofgoo.com/dl2.php?lk=demo"
- elog "and download ${A} and place it in ${DISTDIR}"
+ elog "and download ${A} and place it in your DISTDIR directory."
else
- elog "Download ${A} from ${HOMEPAGE} and place it in ${DISTDIR}"
+ elog "Download ${A} from ${HOMEPAGE}"
+ elog "and place it in your DISTDIR directory."
fi
}
@@ -48,7 +48,7 @@ src_install() {
exeinto "${dir}"
doexe ${MY_PN%Demo}{,.$(usex amd64 bin64 bin32)}
- games_make_wrapper ${PN} "${dir}"/${MY_PN%Demo}
+ make_wrapper ${PN} "${dir}"/${MY_PN%Demo}
insinto "${dir}"
doins -r icons properties res
@@ -61,7 +61,6 @@ src_install() {
fi
dodoc linux-issues.txt
- dohtml readme.html
-
- prepgamesdirs
+ docinto html
+ dodoc readme.html
}