summaryrefslogtreecommitdiff
path: root/games-puzzle/skladnik/skladnik-24.08.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/skladnik/skladnik-24.08.0.ebuild')
-rw-r--r--games-puzzle/skladnik/skladnik-24.08.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/games-puzzle/skladnik/skladnik-24.08.0.ebuild b/games-puzzle/skladnik/skladnik-24.08.0.ebuild
new file mode 100644
index 000000000000..db53201cea58
--- /dev/null
+++ b/games-puzzle/skladnik/skladnik-24.08.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="optional"
+PVCUT=$(ver_cut 1-3)
+KFMIN=6.5.0
+QTMIN=6.7.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="The Japanese warehouse keeper sokoban game"
+HOMEPAGE="https://apps.kde.org/skladnik/ https://invent.kde.org/games/skladnik"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[gui,widgets]
+ >=kde-apps/libkdegames-${PVCUT}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/kcrash-${KFMIN}:6
+ >=kde-frameworks/kdbusaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:6
+ >=kde-frameworks/kxmlgui-${KFMIN}:6
+"
+DEPEND="${RDEPEND}"
+BDEPEND="media-gfx/povray"