summaryrefslogtreecommitdiff
path: root/games-puzzle/ksokoban/ksokoban-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/ksokoban/ksokoban-9999.ebuild')
-rw-r--r--games-puzzle/ksokoban/ksokoban-9999.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/games-puzzle/ksokoban/ksokoban-9999.ebuild b/games-puzzle/ksokoban/ksokoban-9999.ebuild
new file mode 100644
index 000000000000..248af7967e33
--- /dev/null
+++ b/games-puzzle/ksokoban/ksokoban-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+if [[ ${PV} == "9999" ]]; then
+ inherit mercurial
+ EHG_REPO_URI="http://hg.code.sf.net/p/ksokoban/code"
+else
+ SRC_URI="https://dev.gentoo.org/~bircoph/distfiles/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+inherit cmake-utils
+DESCRIPTION="The japanese warehouse keeper game"
+HOMEPAGE="https://sourceforge.net/projects/ksokoban/"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="kde-frameworks/kdelibs:4"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+CMAKE_IN_SOURCE_BUILD="yes"
+
+src_prepare() {
+ sed -i 's/%m//' "data/${PN}.desktop" || die "sed for desktop file failed"
+}
+
+# source lacks install target
+src_install() {
+ dobin ksokoban
+ dodoc AUTHORS NEWS TODO
+ domenu "data/${PN}.desktop"
+ for i in 16 22 32 48 64 128; do
+ doicon -s "${i}" "data/hi${i}-app-${PN}.png"
+ done
+}