summaryrefslogtreecommitdiff
path: root/games-puzzle/hexamine/hexamine-0.2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/hexamine/hexamine-0.2.1.ebuild')
-rw-r--r--games-puzzle/hexamine/hexamine-0.2.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/games-puzzle/hexamine/hexamine-0.2.1.ebuild b/games-puzzle/hexamine/hexamine-0.2.1.ebuild
new file mode 100644
index 000000000000..e80eb0a10503
--- /dev/null
+++ b/games-puzzle/hexamine/hexamine-0.2.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1 games
+
+DESCRIPTION="Hexagonal Minesweeper"
+HOMEPAGE="https://sourceforge.net/projects/hexamine"
+SRC_URI="mirror://sourceforge/hexamine/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-python/pygame
+ ${PYTHON_DEPS}"
+DEPEND="${PYTHON_DEPS}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ games_pkg_setup
+}
+
+src_prepare() {
+ # Modify game data directory
+ sed -i \
+ -e "s:\`dirname \$0\`:${GAMES_DATADIR}/${PN}:" \
+ -e "s:\./hexamine:exec ${EPYTHON} &:" \
+ hexamine || die
+}
+
+src_install() {
+ dogamesbin hexamine
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r hexamine.* skins
+ dodoc ABOUT README
+ prepgamesdirs
+}