summaryrefslogtreecommitdiff
path: root/games-puzzle/fbg/fbg-0.9-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/fbg/fbg-0.9-r2.ebuild')
-rw-r--r--games-puzzle/fbg/fbg-0.9-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/games-puzzle/fbg/fbg-0.9-r2.ebuild b/games-puzzle/fbg/fbg-0.9-r2.ebuild
new file mode 100644
index 000000000000..b0c84fa8eeca
--- /dev/null
+++ b/games-puzzle/fbg/fbg-0.9-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="A Tetris clone written in OpenGL"
+HOMEPAGE="http://fbg.sourceforge.net/"
+SRC_URI="mirror://sourceforge/fbg/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="virtual/opengl
+ virtual/glu
+ dev-games/physfs
+ media-libs/libsdl[opengl,video]
+ media-libs/libmikmod
+ x11-libs/libXt"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ sed -i \
+ -e "/FBGDATADIR=/s:\".*\":\"/usr/share/${PN}\":" \
+ -e '/^datadir=/d' \
+ configure || die
+}
+
+src_configure() {
+ econf --disable-fbglaunch
+}
+
+src_install() {
+ default
+ newicon startfbg/icon.xpm ${PN}.xpm
+ make_desktop_entry ${PN} "Falling Block Game" ${PN}
+ rm -rf "${ED}/usr/doc"
+}