summaryrefslogtreecommitdiff
path: root/games-puzzle/construo/construo-0.2.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/construo/construo-0.2.2-r1.ebuild')
-rw-r--r--games-puzzle/construo/construo-0.2.2-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/games-puzzle/construo/construo-0.2.2-r1.ebuild b/games-puzzle/construo/construo-0.2.2-r1.ebuild
new file mode 100644
index 000000000000..4370d583ab81
--- /dev/null
+++ b/games-puzzle/construo/construo-0.2.2-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools desktop
+
+DESCRIPTION="2d construction toy with objects that react on physical forces"
+HOMEPAGE="http://www.nongnu.org/construo/"
+SRC_URI="http://freesoftware.fsf.org/download/construo/construo.pkg/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ virtual/opengl
+ virtual/glu
+ media-libs/freeglut
+ x11-libs/libXxf86vm
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+src_prepare() {
+ default
+ eapply \
+ "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-lGLU.patch
+ sed -i -e 's/^bindir=.*/bindir=@bindir@/' Makefile.am || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ make_desktop_entry "${PN}.glut" "${PN}.glut"
+ make_desktop_entry "${PN}.x11" "${PN}.x11"
+}