summaryrefslogtreecommitdiff
path: root/games-mud/mudix/mudix-4.3-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-mud/mudix/mudix-4.3-r2.ebuild')
-rw-r--r--games-mud/mudix/mudix-4.3-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/games-mud/mudix/mudix-4.3-r2.ebuild b/games-mud/mudix/mudix-4.3-r2.ebuild
new file mode 100644
index 000000000000..067ddf344613
--- /dev/null
+++ b/games-mud/mudix/mudix-4.3-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A small, stable MUD client for the console"
+HOMEPAGE="http://dw.nl.eu.org/mudix.html"
+SRC_URI="http://dw.nl.eu.org/mudix/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses:0"
+RDEPEND=${DEPEND}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-as-needed.patch
+)
+
+src_compile() {
+ emake -C src O_FLAGS="${CFLAGS}"
+}
+
+src_install () {
+ dobin mudix
+ dodoc README sample.usr
+}