summaryrefslogtreecommitdiff
path: root/games-mud/mudix/mudix-4.3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-mud/mudix/mudix-4.3-r1.ebuild')
-rw-r--r--games-mud/mudix/mudix-4.3-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/games-mud/mudix/mudix-4.3-r1.ebuild b/games-mud/mudix/mudix-4.3-r1.ebuild
new file mode 100644
index 000000000000..99e3b6e6ad3b
--- /dev/null
+++ b/games-mud/mudix/mudix-4.3-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="A small, stable MUD client for the console"
+HOMEPAGE="http://dw.nl.eu.org/mudix.html"
+SRC_URI="http://dw.nl.eu.org/mudix/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses:0"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+}
+
+src_compile() {
+ emake -C src O_FLAGS="${CFLAGS}"
+}
+
+src_install () {
+ dogamesbin mudix
+ dodoc README sample.usr
+ prepgamesdirs
+}