summaryrefslogtreecommitdiff
path: root/games-mud/lyntin/lyntin-4.2-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-mud/lyntin/lyntin-4.2-r2.ebuild')
-rw-r--r--games-mud/lyntin/lyntin-4.2-r2.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/games-mud/lyntin/lyntin-4.2-r2.ebuild b/games-mud/lyntin/lyntin-4.2-r2.ebuild
new file mode 100644
index 000000000000..a579a566c971
--- /dev/null
+++ b/games-mud/lyntin/lyntin-4.2-r2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="tk?"
+
+inherit distutils-r1
+
+DESCRIPTION="tintin mud client clone implemented in Python"
+HOMEPAGE="http://lyntin.sourceforge.net/"
+SRC_URI="mirror://sourceforge/lyntin/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="tk"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+DOCS=( COMMANDS PKG-INFO HACKING README )
+
+python_install() {
+ distutils-r1_python_install --install-scripts=/usr/bin
+}
+
+src_prepare() {
+ distutils-r1_src_prepare
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+src_install() {
+ distutils-r1_src_install
+}
+
+pkg_postinst() {
+ if use tk ; then
+ elog "To start lyntin in GUI mode, create a config file"
+ elog "with this in it:"
+ elog
+ elog "[Lyntin]"
+ elog "ui: tk"
+ elog
+ elog "Then start lyntin like this:"
+ elog
+ elog "runlyntin -c /path/to/config_file\n"
+ fi
+}