summaryrefslogtreecommitdiff
path: root/games-mud/crystal/crystal-0.2.4-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-mud/crystal/crystal-0.2.4-r1.ebuild')
-rw-r--r--games-mud/crystal/crystal-0.2.4-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/games-mud/crystal/crystal-0.2.4-r1.ebuild b/games-mud/crystal/crystal-0.2.4-r1.ebuild
new file mode 100644
index 000000000000..c5f5e04e44bf
--- /dev/null
+++ b/games-mud/crystal/crystal-0.2.4-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils
+
+DESCRIPTION="The crystal MUD client"
+HOMEPAGE="http://www.evilmagic.org/crystal/"
+SRC_URI="http://www.evilmagic.org/dist/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/openssl:0=
+ sys-libs/ncurses:0=
+ sys-libs/zlib
+ virtual/libiconv"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc43.patch
+ "${FILESDIR}"/${P}-build.patch
+)
+
+src_prepare() {
+ default
+
+ # avoid colliding with xscreensaver (bug #281191)
+ mv crystal.6 crystal-mud.6 || die
+ mv configure.in configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-scripting
+}