summaryrefslogtreecommitdiff
path: root/games-misc/xcruiser/xcruiser-0.30-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-misc/xcruiser/xcruiser-0.30-r1.ebuild')
-rw-r--r--games-misc/xcruiser/xcruiser-0.30-r1.ebuild26
1 files changed, 18 insertions, 8 deletions
diff --git a/games-misc/xcruiser/xcruiser-0.30-r1.ebuild b/games-misc/xcruiser/xcruiser-0.30-r1.ebuild
index c5f7a85927f4..0b64f9c5698b 100644
--- a/games-misc/xcruiser/xcruiser-0.30-r1.ebuild
+++ b/games-misc/xcruiser/xcruiser-0.30-r1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
+
inherit toolchain-funcs
DESCRIPTION="Fly about 3D-formed file system"
@@ -11,22 +12,31 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
RESTRICT="test"
RDEPEND="x11-libs/libXaw"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
app-text/rman
x11-misc/gccmakedep
- x11-misc/imake"
+ >=x11-misc/imake-1.0.8-r1"
+
+src_configure() {
+ CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
+ IMAKECPP="${IMAKECPP:-$(tc-getCPP)}" xmkmf -a || die
+}
src_compile() {
- xmkmf -a
- emake CC=$(tc-getCC) CDEBUGFLAGS="${CFLAGS}" LOCAL_LDFLAGS="${LDFLAGS}"
+ local myemakeargs=(
+ CC="$(tc-getCC)"
+ CDEBUGFLAGS="${CFLAGS}"
+ LOCAL_LDFLAGS="${LDFLAGS}"
+ )
+ emake "${myemakeargs[@]}"
}
src_install() {
dobin xcruiser
- dodoc CHANGES README README.jp TODO
newman xcruiser.man xcruiser.1
+ einstalldocs
}