summaryrefslogtreecommitdiff
path: root/games-misc/katawa-shoujo
diff options
context:
space:
mode:
Diffstat (limited to 'games-misc/katawa-shoujo')
-rw-r--r--games-misc/katawa-shoujo/Manifest5
-rw-r--r--games-misc/katawa-shoujo/katawa-shoujo-1.3.1-r1.ebuild84
-rw-r--r--games-misc/katawa-shoujo/metadata.xml30
3 files changed, 119 insertions, 0 deletions
diff --git a/games-misc/katawa-shoujo/Manifest b/games-misc/katawa-shoujo/Manifest
new file mode 100644
index 000000000000..800e2e19acd9
--- /dev/null
+++ b/games-misc/katawa-shoujo/Manifest
@@ -0,0 +1,5 @@
+DIST katawa-shoujo-1.3.1.tar.bz2 496188604 BLAKE2B a27fbc84ac0594790ad5b77e6c7e49c19c2b4716b1e5e516171b593211f1d5f2ca1bddc3e0ebb92420b7529b4b2fdff7b0732bb61b5aa2acdaf45e33dd713497 SHA512 d5f1b49c60b70b272dd5d62c1d49cb9e3c17e3f77339fc593db2122f1c140005bc23ecb7ad9b0d93c0701c77f9bcfcd5c1c67db1cbe3034a3be42a4309387809
+DIST katawa-shoujo-256.png 59803 BLAKE2B 2acf08b55ae3e776ac260b552fd6a04b17a3246534702fbf39bdfcd49348778c1703d0ad135bca7933a82de3d983b9c19c255ed72006b7ca2c73acc157f6e9cb SHA512 7d920c24f4182ba72d5b3d641d7d373c166ca4c7d0b6a396f5e3b9281cb43f7e6e8e761f2f181ff061705118b3080807866fcd290d2b471e98c3a584d5fa8e0e
+DIST katawa-shoujo-48.png 3621 BLAKE2B 1f9ad61bcbd90218d6b11269e7c93a5b2816eee0640f191027e656978dc968a673a3ff02deee0d960a188c2893dde95a45134a847c58c627e1fd7ff2e5b28da1 SHA512 ad24156cf446ffe92068baaa6d512e6bab90587db5ce01b3c18e6c42bb9b8c91f7eae3e9547099d3f8f0a5d3f144676c3499c0a38d9af845abf79e153b543bef
+EBUILD katawa-shoujo-1.3.1-r1.ebuild 2070 BLAKE2B c87f54f99987c01f2e46b0a16fff0a097e35c754eb82cfd5c6bd966e65e24938029b9de694b2214727afe4119f56408db43cd5fcb2d0d1af67cb6617ac5eb772 SHA512 443e69ba7fca1375ae57420dd9b2c0f9579064018e424e83808e0eb75124ff557eebadb29ee9eab6a8f96d60021d3ce8a683b081129e1d1d77cb63b4184f03e7
+MISC metadata.xml 1219 BLAKE2B 6e95455f55b87eef6d4d079ff28a6d29f336db425386a81d9067c02ae9b2bc6be5168be0999cfe6a9572be5d1560eb918db37d5dca4e537746133ff8be3f1574 SHA512 3482903b61840dabd8e30941699c2e1319f7d0a384bded5bead56def041b6592e69a0a3a9210c361c875082362dbe3c6c80356e0e12cbe7ecff3ea4eabc8ea30
diff --git a/games-misc/katawa-shoujo/katawa-shoujo-1.3.1-r1.ebuild b/games-misc/katawa-shoujo/katawa-shoujo-1.3.1-r1.ebuild
new file mode 100644
index 000000000000..aa8f03ef61cc
--- /dev/null
+++ b/games-misc/katawa-shoujo/katawa-shoujo-1.3.1-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils gnome2-utils
+
+DESCRIPTION="Bishoujo-style visual novel by Four Leaf Studios"
+HOMEPAGE="https://www.katawa-shoujo.com"
+SRC_URI="https://dl.katawa-shoujo.com/gold_1.3.1/%5B4ls%5D_katawa_shoujo_1.3.1-%5Blinux-x86%5D%5B18161880%5D.tar.bz2 -> ${P}.tar.bz2
+ https://dev.gentoo.org/~hasufell/distfiles/katawa-shoujo-48.png
+ https://dev.gentoo.org/~hasufell/distfiles/katawa-shoujo-256.png"
+
+# bundled renpy includes licenses of all libraries
+LICENSE="
+ CC-BY-NC-ND-3.0
+ !system-renpy? ( MIT PSF-2 LGPL-2.1 || ( FTL GPL-2+ ) IJG libpng ZLIB BZIP2 )
+"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="doc +system-renpy"
+REQUIRED_USE="!system-renpy? ( || ( amd64 x86 ) )"
+
+RDEPEND="system-renpy? ( games-engines/renpy:6.99 )"
+DEPEND=""
+
+# Binaries are built extremely weirdly, resulting in errors like:
+# BFD: Not enough room for program headers, try linking with -N
+#
+# Technically, we could make this unconditional because there are no other
+# binaries, but it's still good practice.
+RESTRICT="!system-renpy? ( strip )"
+
+QA_PREBUILT="/opt/${PN}/lib/*"
+
+S="${WORKDIR}/Katawa Shoujo-${PV}-linux"
+
+src_install() {
+ if use system-renpy; then
+ insinto "/usr/share/${PN}"
+ doins -r game/.
+ make_wrapper ${PN} "renpy '/usr/share/${PN}'"
+ else
+ insinto "/opt/${PN}"
+ doins -r game localizations renpy "Katawa Shoujo."{py,sh}
+
+ local host="${CTARGET:-${CHOST}}"
+ local arch="${host%%-*}"
+
+ cd lib
+ insinto "/opt/${PN}/lib"
+ doins -r linux-${arch} pythonlib2.7
+ cd ..
+
+ fperms +x "/opt/${PN}/lib/linux-${arch}/"{python,"Katawa Shoujo"} \
+ "/opt/${PN}/Katawa Shoujo."{py,sh}
+
+ make_wrapper ${PN} "./Katawa\ Shoujo.sh" "/opt/${PN}"
+ fi
+
+ local i
+ for i in 48 256; do
+ newicon -s ${i} "${DISTDIR}"/${PN}-${i}.png ${PN}.png
+ done
+
+ make_desktop_entry ${PN} "Katawa Shoujo"
+
+ if use doc; then
+ dodoc "Game Manual.pdf"
+ fi
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-misc/katawa-shoujo/metadata.xml b/games-misc/katawa-shoujo/metadata.xml
new file mode 100644
index 000000000000..7e45f8f26dae
--- /dev/null
+++ b/games-misc/katawa-shoujo/metadata.xml
@@ -0,0 +1,30 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>alex_y_xu@yahoo.ca</email>
+ <name>Alex Xu</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <use>
+ <flag name="system-renpy">Use <pkg>games-engines/renpy</pkg> instead of the bundled one (experimental)</flag>
+ </use>
+ <longdescription>
+ Katawa Shoujo is a bishoujo-style visual novel set in the fictional
+ Yamaku High School for disabled children, located somewhere in modern
+ Japan. Hisao Nakai, a normal boy living a normal life, has his life
+ turned upside down when a congenital heart defect forces him to move to
+ a new school after a long hospitalization. Despite his difficulties,
+ Hisao is able to find friends—and perhaps love, if he plays his cards
+ right. There are five main paths corresponding to the 5 main female
+ characters, each path following the storyline pertaining to that
+ character.
+ </longdescription>
+</pkgmetadata>