summaryrefslogtreecommitdiff
path: root/games-misc/bsod
diff options
context:
space:
mode:
Diffstat (limited to 'games-misc/bsod')
-rw-r--r--games-misc/bsod/Manifest4
-rw-r--r--games-misc/bsod/bsod-0.1-r1.ebuild32
-rw-r--r--games-misc/bsod/files/bsod-0.1-Makefile.patch21
-rw-r--r--games-misc/bsod/metadata.xml8
4 files changed, 65 insertions, 0 deletions
diff --git a/games-misc/bsod/Manifest b/games-misc/bsod/Manifest
new file mode 100644
index 000000000000..e26dee1ec69b
--- /dev/null
+++ b/games-misc/bsod/Manifest
@@ -0,0 +1,4 @@
+AUX bsod-0.1-Makefile.patch 464 BLAKE2B ff9a1653fbbdde19337b5bfc1ba19467917acd9107ca62ed42def5cfb1262092b46e1e5de70f105ae3fc9d5a7199449f677651a909f81f7b7dd4c7fe84e986c7 SHA512 f5cb0912a1b851a7f6bd7d4cf861b11a1832a47674d67632343474f5a7c6e5dbde7c2a1f4e217e2df293c8ea9c780d7de6aa14fa6ce5d07a2b5704d57edbe2a3
+DIST bsod-0.1.tgz 10128 BLAKE2B e0869bd21beb38f369bb010b5a7d73bd3182a8531c9460cb279cedb498ce37830f39f97a30dfad567a14b12be5d50743a097720e3665306f2bef43085d339be9 SHA512 2b3087ee495c83f41c2c582dc1c391ce5b73600244b6183abbcd36a3f88caf16987250d4ad23eb3a556b014669ddd84947e6cddeb8d4c89e12c9bacc545299c8
+EBUILD bsod-0.1-r1.ebuild 600 BLAKE2B cc30ff1ccfccff1d84f95a664a766daaae3e84b5c3704013e116fc010c6c95aa86acf83e563630a30c69bca68369f70211741922f1268d8660c4df4b63a7a582 SHA512 82bb7e45283cc0466c7d917b2b780117a9253fcb9105e10a29dea63541bae8d6f9be14b0e4299db9896ed7ceeffda5cf2c6944d6ffe995fb133aa54db72ac978
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-misc/bsod/bsod-0.1-r1.ebuild b/games-misc/bsod/bsod-0.1-r1.ebuild
new file mode 100644
index 000000000000..3c9c455788c7
--- /dev/null
+++ b/games-misc/bsod/bsod-0.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils toolchain-funcs
+
+DESCRIPTION="This program will let you experience the authentic Microsoft Windows experience"
+HOMEPAGE="http://www.vanheusden.com/bsod/"
+SRC_URI="http://www.vanheusden.com/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="sys-libs/ncurses:0"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-Makefile.patch
+)
+
+src_prepare() {
+ default
+ tc-export PKG_CONFIG
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc Changes
+}
diff --git a/games-misc/bsod/files/bsod-0.1-Makefile.patch b/games-misc/bsod/files/bsod-0.1-Makefile.patch
new file mode 100644
index 000000000000..b7699c80403b
--- /dev/null
+++ b/games-misc/bsod/files/bsod-0.1-Makefile.patch
@@ -0,0 +1,21 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,15 +1,15 @@
+ VERSION=0.1
+
+ DEBUG=-g -pedantic #-pg #-fprofile-arcs
+-LDFLAGS=-lncurses $(DEBUG)
+-CFLAGS+=-O2 -Wall -DVERSION=\"$(VERSION)\" $(DEBUG)
++LDLIBS=$(shell ${PKG_CONFIG} --libs ncurses)
++CFLAGS+=-Wall -DVERSION=\"$(VERSION)\"
+
+ OBJS=bsod.o
+
+ all: bsod
+
+ bsod: $(OBJS)
+- $(CC) -Wall $(OBJS) $(LDFLAGS) -o bsod
++ $(CC) $(LDFLAGS) $(CFLAGS) $(OBJS) $(LDLIBS) -o bsod
+
+ install: bsod
+ cp bsod $(DESTDIR)/usr/local/bin
diff --git a/games-misc/bsod/metadata.xml b/games-misc/bsod/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-misc/bsod/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>