summaryrefslogtreecommitdiff
path: root/games-kids/lletters/files
diff options
context:
space:
mode:
Diffstat (limited to 'games-kids/lletters/files')
-rw-r--r--games-kids/lletters/files/lletters-0.1.95-build-2.patch60
-rw-r--r--games-kids/lletters/files/lletters-0.1.95-make-382.patch23
-rw-r--r--games-kids/lletters/files/lletters-0.1.95-underlink.patch11
3 files changed, 94 insertions, 0 deletions
diff --git a/games-kids/lletters/files/lletters-0.1.95-build-2.patch b/games-kids/lletters/files/lletters-0.1.95-build-2.patch
new file mode 100644
index 000000000000..41e10517faf9
--- /dev/null
+++ b/games-kids/lletters/files/lletters-0.1.95-build-2.patch
@@ -0,0 +1,60 @@
+diff -ur lletters-0.1.95.orig/libqdwav/Makefile.in lletters-0.1.95/libqdwav/Makefile.in
+--- lletters-0.1.95.orig/libqdwav/Makefile.in 2008-04-09 19:23:13.000000000 +0300
++++ lletters-0.1.95/libqdwav/Makefile.in 2008-04-09 19:48:08.000000000 +0300
+@@ -225,7 +225,6 @@
+ sysconfdir = @sysconfdir@
+ target_alias = @target_alias@
+ noinst_LIBRARIES = libqdwav.a
+-AM_CFLAGS = -O2
+ libqdwav_a_SOURCES = wav_read.c wav_write.c
+ noinst_HEADERS = wav_lib.h
+ all: all-am
+diff -ur lletters-0.1.95.orig/libqdwav/wav_read.c lletters-0.1.95/libqdwav/wav_read.c
+--- lletters-0.1.95.orig/libqdwav/wav_read.c 2000-02-21 09:53:08.000000000 +0200
++++ lletters-0.1.95/libqdwav/wav_read.c 2008-04-09 19:51:23.000000000 +0300
+@@ -1,5 +1,6 @@
+ /* operations for verifying and reading wav files. */
+
++#include <string.h> /* for strs */
+ #include <stdio.h>
+ #include <fcntl.h>
+ #include <sys/stat.h>
+diff -ur lletters-0.1.95.orig/libqdwav/wav_write.c lletters-0.1.95/libqdwav/wav_write.c
+--- lletters-0.1.95.orig/libqdwav/wav_write.c 2008-04-09 19:23:13.000000000 +0300
++++ lletters-0.1.95/libqdwav/wav_write.c 2008-04-09 19:51:28.000000000 +0300
+@@ -1,3 +1,4 @@
++#include <string.h> /* for strs */
+ #include <stdio.h>
+ #include <fcntl.h>
+ #include <signal.h>
+diff -ur lletters-0.1.95.orig/list.c lletters-0.1.95/list.c
+--- lletters-0.1.95.orig/list.c 2000-02-23 06:54:57.000000000 +0200
++++ lletters-0.1.95/list.c 2008-04-09 19:51:35.000000000 +0300
+@@ -1,3 +1,4 @@
++#include <string.h> /* for strs */
+ #include "lletters.h"
+
+ /* prototype std lib functions */
+diff -ur lletters-0.1.95.orig/po/Makefile.in.in lletters-0.1.95/po/Makefile.in.in
+--- lletters-0.1.95.orig/po/Makefile.in.in 2008-04-09 19:23:13.000000000 +0300
++++ lletters-0.1.95/po/Makefile.in.in 2008-04-09 19:48:08.000000000 +0300
+@@ -111,9 +111,9 @@
+ install-data-no: all
+ install-data-yes: all
+ if test -r "$(MKINSTALLDIRS)"; then \
+- $(MKINSTALLDIRS) $(datadir); \
++ $(MKINSTALLDIRS) $(DESTDIR)$(datadir); \
+ else \
+- $(SHELL) $(top_srcdir)/mkinstalldirs $(datadir); \
++ $(SHELL) $(top_srcdir)/mkinstalldirs $(DESTDIR)$(datadir); \
+ fi
+ @catalogs='$(CATALOGS)'; \
+ for cat in $$catalogs; do \
+@@ -122,6 +122,7 @@
+ *.gmo) destdir=$(gnulocaledir);; \
+ *) destdir=$(localedir);; \
+ esac; \
++ destdir="$(DESTDIR)$$destdir"; \
+ lang=`echo $$cat | sed 's/\$(CATOBJEXT)$$//'`; \
+ dir=$$destdir/$$lang/LC_MESSAGES; \
+ if test -r "$(MKINSTALLDIRS)"; then \
diff --git a/games-kids/lletters/files/lletters-0.1.95-make-382.patch b/games-kids/lletters/files/lletters-0.1.95-make-382.patch
new file mode 100644
index 000000000000..103c26a1a342
--- /dev/null
+++ b/games-kids/lletters/files/lletters-0.1.95-make-382.patch
@@ -0,0 +1,23 @@
+http://bugs.gentoo.org/340599
+
+--- a/intl/Makefile.in
++++ b/intl/Makefile.in
+@@ -202,12 +202,12 @@
+ # The dependency for intlh.inst is different in gettext and all other
+ # packages. Because we cannot you GNU make features we have to solve
+ # the problem while rewriting Makefile.in.
+-@GT_YES@intlh.inst: intlh.inst.in ../config.status
+-@GT_YES@ cd .. \
+-@GT_YES@ && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= \
+-@GT_YES@ $(SHELL) ./config.status
+-@GT_NO@.PHONY: intlh.inst
+-@GT_NO@intlh.inst:
++intlh.inst: intlh.inst.in ../config.status
++ cd .. \
++ && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= \
++ $(SHELL) ./config.status
++.PHONY: intlh.inst
++intlh.inst:
+
+ # Tell versions [3.59,3.63) of GNU make not to export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/games-kids/lletters/files/lletters-0.1.95-underlink.patch b/games-kids/lletters/files/lletters-0.1.95-underlink.patch
new file mode 100644
index 000000000000..1d6401379c5d
--- /dev/null
+++ b/games-kids/lletters/files/lletters-0.1.95-underlink.patch
@@ -0,0 +1,11 @@
+--- a/Makefile.in 2011-05-24 10:47:30.276355207 +0200
++++ b/Makefile.in 2011-05-24 10:47:53.316795932 +0200
+@@ -265,7 +265,7 @@
+
+ @SOUND_FALSE@lletters_SOURCES = $(lln_CORE)
+ @SOUND_TRUE@lletters_SOURCES = $(lln_CORE) wav_play.c $(sound_CORE)
+-@SOUND_TRUE@lletters_LDADD = libqdwav/libqdwav.a -lgdk_pixbuf-2.0 -lglib-2.0 -lgtk-x11-2.0
++@SOUND_TRUE@lletters_LDADD = libqdwav/libqdwav.a @GTK_LIBS@
+
+ #lletters_LDADD = #@GTK_LIBS@
+ @SOUND_FALSE@SUBDIRS = intl po images lang