summaryrefslogtreecommitdiff
path: root/games-fps/ut2004-hamsterbash/ut2004-hamsterbash-1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/ut2004-hamsterbash/ut2004-hamsterbash-1.ebuild')
-rw-r--r--games-fps/ut2004-hamsterbash/ut2004-hamsterbash-1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/games-fps/ut2004-hamsterbash/ut2004-hamsterbash-1.ebuild b/games-fps/ut2004-hamsterbash/ut2004-hamsterbash-1.ebuild
new file mode 100644
index 000000000000..deff807a29dd
--- /dev/null
+++ b/games-fps/ut2004-hamsterbash/ut2004-hamsterbash-1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MOD_DESC="Cute and violent hamster cage rampage mod"
+MOD_NAME="Hamster Bash"
+MOD_DIR="hamsterbash"
+
+inherit unpacker games games-mods
+
+HOMEPAGE="https://www.moddb.com/mods/hamsterbash"
+SRC_URI="HamsterBashFinal.zip"
+
+LICENSE="freedist"
+KEYWORDS="~amd64 ~x86"
+IUSE="dedicated opengl"
+RESTRICT="fetch"
+
+pkg_nofetch() {
+ elog "Please download ${SRC_URI} from:"
+ elog "${HOMEPAGE}"
+ elog "and move it to ${DISTDIR}"
+}
+
+src_prepare() {
+ mv -f HamsterBash ${MOD_DIR} || die
+ rm -rf System
+}