summaryrefslogtreecommitdiff
path: root/games-fps/ut2004-bonuspack-ece
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/ut2004-bonuspack-ece')
-rw-r--r--games-fps/ut2004-bonuspack-ece/Manifest4
-rw-r--r--games-fps/ut2004-bonuspack-ece/metadata.xml8
-rw-r--r--games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1-r3.ebuild56
3 files changed, 68 insertions, 0 deletions
diff --git a/games-fps/ut2004-bonuspack-ece/Manifest b/games-fps/ut2004-bonuspack-ece/Manifest
new file mode 100644
index 000000000000..39652d72e6e5
--- /dev/null
+++ b/games-fps/ut2004-bonuspack-ece/Manifest
@@ -0,0 +1,4 @@
+DIST UT2004-ONSBonusMapPack.zip 11018471 BLAKE2B bc915d6942c321df4031b02eaa25f83793b3fa1f2bb916c5d413c5569a3f887b6517fc4dceb8cb914e22be62f58512e727a41d5efbc6066113be12a9da9621d0 SHA512 8193375b89cd6fbc8b00de195797099c128fcf5cb73757bbc57d3c5350c497a878eaf0200f2e0711bf062e25c5d170e05b055c63f85b908b18dcc89572d71fd2
+DIST ut2004megapack-linux.tar.bz2 203124107 BLAKE2B 1459e2638181411446ec5679bceb44023382b3533951478ee06c274199688f3bbe341d7f7806299a332373791b6d0a9e1b57efdc6a13a5983220e0adbc413118 SHA512 4ae5eec0622c2bd96dfc162541bc0771399b012fb00f022282bc8c34600cb8e9bb7c18a52dd55fbef6f16fedaf225e301c46077a6accd001f4c77ddad89ed17b
+EBUILD ut2004-bonuspack-ece-1-r3.ebuild 1754 BLAKE2B c9e1b4c1f06416739670ef7d2af8a3ab5c57d5fa970a4f103f3fa5c4e570a5a85687c268c63d5cf679ba40bfc2036ffc7ba77d66b203eab17f5e69514d6d9278 SHA512 4136dd65c99555dd1bb859e79d4000db11d22e47f7d0846fff15b696a7e282b840dac973352815e85c4c14a4ca43d3cbae0e1eddc21f842cb25d67d960329fa6
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-fps/ut2004-bonuspack-ece/metadata.xml b/games-fps/ut2004-bonuspack-ece/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-fps/ut2004-bonuspack-ece/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1-r3.ebuild b/games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1-r3.ebuild
new file mode 100644
index 000000000000..e5ebe2ab3b90
--- /dev/null
+++ b/games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1-r3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MOD_DESC="Editor's Choice Edition bonus pack"
+MOD_NAME="Editor's Choice Edition"
+
+inherit games games-mods
+
+MY_P="ut2004megapack-linux.tar.bz2"
+HOMEPAGE="http://www.unrealtournament2004.com/"
+SRC_URI="http://ut2004.ut-files.com/BonusPacks/${MY_P}
+ http://unrealmassdestruction.com/downloads/ut2k4/essentials/UT2004-ONSBonusMapPack.zip"
+
+LICENSE="ut2003"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${MY_P}
+ cd UT2004MegaPack/Maps || die
+ unpack UT2004-ONSBonusMapPack.zip # bug #278002
+}
+
+src_prepare() {
+ mv -f UT2004MegaPack/* . || die
+ rmdir UT2004MegaPack || die
+
+ rm -r Music Speech || die
+
+ # Remove megapack files which are not in ece
+ rm Animations/ONSNewTank-A.ukx || die
+ rm Help/ReadMePatch.int.txt || die
+ # Help/{DebuggerLogo.bmp,InstallerLogo.bmp,Unreal.ico,UnrealEd.ico}
+ # are not in megapack.
+ # Keep new Help/UT2004Logo.bmp
+ # Manual dir does not exist in megapack
+ rm Maps/{AS*,CTF*,DM*} || die
+ rm Sounds/A_Announcer_BP2.uax || die
+ rm StaticMeshes/{JumpShipObjects.usx,Ty_RocketSMeshes.usx} || die
+ rm System/{A*,b*,B*,CacheRecords.ucl} || die
+ rm System/{*.det,*.est,*.frt,*.itt,*.kot} || die
+ rm System/{CTF*,D*,Editor*,G*,I*,L*,Onslaught.*,*.md5} || die
+ rm System/{u*,U*,V*,X*,Core.u,Engine.u,F*,*.ucl,Sk*} || die
+ rm Textures/{J*,j*,T*} || die
+ rm -r Web || die
+
+ # The file lists of ut2004-3369-r1 and -r2 are identical
+ # Remove files owned by ut2004-3369-r2
+ rm Help/UT2004Logo.bmp || die
+ # The 2 Manifest files have not changed
+ rm System/{Manifest.in{i,t},OnslaughtFull.int} || die
+ rm System/{Core.int,Engine.int,Setup.int,Window.int} || die
+ rm System/{OnslaughtFull.u,OnslaughtBP.u} || die
+}