summaryrefslogtreecommitdiff
path: root/games-fps/ut2003-bonuspack-epic
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/ut2003-bonuspack-epic')
-rw-r--r--games-fps/ut2003-bonuspack-epic/Manifest4
-rw-r--r--games-fps/ut2003-bonuspack-epic/files/epic-installer48
-rw-r--r--games-fps/ut2003-bonuspack-epic/metadata.xml8
-rw-r--r--games-fps/ut2003-bonuspack-epic/ut2003-bonuspack-epic-1.ebuild110
4 files changed, 170 insertions, 0 deletions
diff --git a/games-fps/ut2003-bonuspack-epic/Manifest b/games-fps/ut2003-bonuspack-epic/Manifest
new file mode 100644
index 000000000000..43f229037b16
--- /dev/null
+++ b/games-fps/ut2003-bonuspack-epic/Manifest
@@ -0,0 +1,4 @@
+AUX epic-installer 925 BLAKE2B 4d86c44875d58a01e4226fc746aba8d3fa44875554c4aa4ed150797a4d157915cf0335420a019f6b9d32689e1f34f774cfd8ee756996d890240ff558d5bf22a9 SHA512 0e49953e28c1be196c67d5d29a5f6ac0f636f1315a18bf883c35c8236b74f4a5aea45693fba013578592bb0601a9eaa734446cfd533af70db9a24371162c2524
+DIST UT2003-epicbonuspackone.exe 156913152 BLAKE2B ea420203dfd7f12a1f790d06875af34073fa30764a7184d6945e97063291100ef4377025afb86fab2038f7a824d60e2c93b991202465864de993456b10638f94 SHA512 26fa06637c6a99704d11b58f5fe54454f8018c6f07b06b6a9a2075d17b9a9fb7d7155298de5502cefa0f07995f4513ce9531863cef8c344996b5e6dd5fbd339d
+EBUILD ut2003-bonuspack-epic-1.ebuild 2504 BLAKE2B 014935b88571701eabfcd1a0ccabc2fa50fe34cd89674ceac244320529045ae9a0794b87a4ff25474f29ec28ca5f6935f9370bf8a19fa5dbd877bac64822376a SHA512 a761a8651258e62193151ff6d6919d975bc40fcf4663f290309c8322166f242f836d69ac1bcd387176f53b18cf202c263f2e82bd80eabf11140604a2b2d7c8c0
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-fps/ut2003-bonuspack-epic/files/epic-installer b/games-fps/ut2003-bonuspack-epic/files/epic-installer
new file mode 100644
index 000000000000..a8c35aa0c751
--- /dev/null
+++ b/games-fps/ut2003-bonuspack-epic/files/epic-installer
@@ -0,0 +1,48 @@
+#!/bin/bash
+
+if [[ -d $HOME/.ut2003/System ]] ; then
+ cd "$HOME/.ut2003/System"
+ echo "Editing UT2003.ini in $PWD"
+ cat >> UT2003.ini <<EOT
+
+[Xinterface.Tab_AudioSettings]
+BonusPackInfo[1]=(PackageName="AnnouncerEvil.uax",Description="Evil")
+BonusPackInfo[2]=(PackageName="AnnouncerFemale.uax",Description="Female")
+BonusPackInfo[3]=(PackageName="AnnouncerSexy.uax",Description="Aroused")
+
+EOT
+
+ ed UT2003.ini >/dev/null 2>&1 <<EOT
+/\[xInterface.ExtendedConsole\]
+a
+MusicManagerClassName=OGGPlayer.UT2OGGMenu
+.
+wq
+EOT
+
+ ed UT2003.ini >/dev/null 2>&1 <<EOT
+$
+?EditPackages?
+a
+EditPackages=BonusPack
+EditPackages=SkaarjPack
+EditPackages=SkaarjPack_rc
+.
+wq
+EOT
+
+ ed UT2003.ini >/dev/null 2>&1 <<EOT
+$
+?ServerPackages?
+a
+ServerPackages=BonusPack
+ServerPackages=SkaarjPack
+ServerPackages=SkaarjPack_rc
+.
+wq
+EOT
+
+ echo "Editing User.ini in $PWD"
+ sed 's/^F11=.*$/F11=MusicMenu/g' < User.ini > User.ini~~
+ mv User.ini~~ User.ini
+fi
diff --git a/games-fps/ut2003-bonuspack-epic/metadata.xml b/games-fps/ut2003-bonuspack-epic/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-fps/ut2003-bonuspack-epic/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-fps/ut2003-bonuspack-epic/ut2003-bonuspack-epic-1.ebuild b/games-fps/ut2003-bonuspack-epic/ut2003-bonuspack-epic-1.ebuild
new file mode 100644
index 000000000000..00d2d8927eef
--- /dev/null
+++ b/games-fps/ut2003-bonuspack-epic/ut2003-bonuspack-epic-1.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit games
+
+DESCRIPTION="Epic Bonus Pack for UT2003"
+HOMEPAGE="https://www.moddb.com/games/unreal-tournament-2003"
+SRC_URI="http://ftp.student.utwente.nl/pub/games/UT2003/BonusPack/UT2003-epicbonuspackone.exe"
+
+LICENSE="ut2003"
+SLOT="1"
+KEYWORDS="~x86"
+IUSE=""
+RESTRICT="strip"
+
+DEPEND="app-arch/unzip"
+RDEPEND="games-fps/ut2003"
+
+S=${WORKDIR}/UT2003-BonusPack
+
+dir=${GAMES_PREFIX_OPT}/ut2003
+Ddir=${D}/${dir}
+
+src_unpack() {
+ unzip -qq "${DISTDIR}"/${A} || die
+ # This is done since the files are the same
+ rm -f "${S}"/Textures/LastManStanding.utx || die
+}
+
+src_install() {
+ insinto "${dir}"/Help
+ newins "${S}"/Help/BonusPackReadme.txt EpicBonusPack.README
+
+ exeinto "${dir}"
+ doexe "${FILESDIR}"/epic-installer
+ dodir "${dir}"/System
+
+ cp -r "${S}"/{Maps,Sounds,StaticMeshes,Textures} "${Ddir}" || die
+ cp "${S}"/System/{*.{det,est,frt,int,itt,kot,tmt,u},User.ini} "${Ddir}"/System || die
+ cp -v "${S}"/System/Manifest.ini "${Ddir}"/System/Manifest.ini.epic || die
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "You will need to run:"
+ elog "emerge --config =${CATEGORY}/${PF}"
+ elog "to make the necessary changes to the system .ini files."
+ elog
+ elog "Each user whom has already played the game will need to run:"
+ elog " ${dir}/epic-installer"
+ echo
+ elog "to update their configuration files in their home directory."
+ echo
+}
+
+pkg_config() {
+ cd ${dir}/System || die
+ cp Manifest.ini Manifest.ini.pre-epic || die
+ cp ${dir}/System/Manifest.ini.epic Manifest.ini || die
+
+ cp Default.ini Default.ini.pre-epic || die
+ cat >> Default.ini <<EOT
+
+[Xinterface.Tab_AudioSettings]
+BonusPackInfo[1]=(PackageName="AnnouncerEvil.uax",Description="Evil")
+BonusPackInfo[2]=(PackageName="AnnouncerFemale.uax",Description="Female")
+BonusPackInfo[3]=(PackageName="AnnouncerSexy.uax",Description="Aroused")
+
+EOT
+
+ ed Default.ini >/dev/null 2>&1 <<EOT
+/\[xInterface.ExtendedConsole\]
+a
+MusicManagerClassName=OGGPlayer.UT2OGGMenu
+.
+w
+q
+EOT
+
+ ed Default.ini >/dev/null 2>&1 <<EOT
+$
+?EditPackages?
+a
+EditPackages=BonusPack
+EditPackages=SkaarjPack
+EditPackages=SkaarjPack_rc
+.
+w
+q
+EOT
+
+ ed Default.ini >/dev/null 2>&1 <<EOT
+$
+?ServerPackages?
+a
+ServerPackages=BonusPack
+ServerPackages=SkaarjPack
+ServerPackages=SkaarjPack_rc
+.
+w
+q
+EOT
+
+ cp DefUser.ini DefUser.ini.pre-epic || die
+ sed -i 's/^F11=.*$/F11=MusicMenu/g' DefUser.ini || die
+ chown games:games ${dir}/System/*.ini || die
+}