summaryrefslogtreecommitdiff
path: root/games-fps/ut2003-bonuspack-cm
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/ut2003-bonuspack-cm')
-rw-r--r--games-fps/ut2003-bonuspack-cm/Manifest3
-rw-r--r--games-fps/ut2003-bonuspack-cm/metadata.xml11
-rw-r--r--games-fps/ut2003-bonuspack-cm/ut2003-bonuspack-cm-1.ebuild38
3 files changed, 52 insertions, 0 deletions
diff --git a/games-fps/ut2003-bonuspack-cm/Manifest b/games-fps/ut2003-bonuspack-cm/Manifest
new file mode 100644
index 000000000000..f4483b3d052b
--- /dev/null
+++ b/games-fps/ut2003-bonuspack-cm/Manifest
@@ -0,0 +1,3 @@
+DIST cbp2003.zip 149198671 BLAKE2B c5f7352b7fb1e0e6a18c99a6212cd5cb4e5e6144988534f91aed93bf33b031d437e86eebf239f0a49fa20b90ca0ded09e912a96b798bc855d527423f2a299ba7 SHA512 92e136c03f1385a28163718cc6ef1c36e46fbad14c74d0f266dfe3d9f4a5093e1bd02dde54e68f70539ba2c4ee163b1e886529f7e734059a85223ab6f853a474
+EBUILD ut2003-bonuspack-cm-1.ebuild 799 BLAKE2B 61040ee3113609c8eae4fa49fa2a9ccf0663d891e38783d7b0af9f2824b30e6dd6a4f77dc1a28b6201c248b654c6ba1c03ad86d76fa687c125de55caf7ef5157 SHA512 8bd64550a6a770e531aa42a7cf41933860ec363d3e278fdaf57d2969ecf4dda135b7ae81e8ab44b83094b4425e64a304f1ca83f4d47df31276d414b51f4e378b
+MISC metadata.xml 771 BLAKE2B 705c6aa979f650220a52db3ef5d8c5b8b468b28eac8692a2fbe583ed4b3f694fdfe088d64cc3f6d8506494522f8ca11b491e21e322e3f50ff4453e93ce0d543f SHA512 d30d55503e3b3897d2a5093c06a39f684bdf0879214931a360a87637cd62ae1ca019577f42275bf2b4ba28649ab2989b0a2e184998497ddc5ffddbb6ba35ef5e
diff --git a/games-fps/ut2003-bonuspack-cm/metadata.xml b/games-fps/ut2003-bonuspack-cm/metadata.xml
new file mode 100644
index 000000000000..e716a53e0747
--- /dev/null
+++ b/games-fps/ut2003-bonuspack-cm/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+<longdescription>
+Unreal Tounament 2003 is a first-person 3-D shooter and sequel to the 1999 Game of the Year, Unreal Tournament. The game was ported to Linux by Ryan "icculus" Gordon under contract from Epic Games and the Linux installer was released in the retail box. This game is commercial software and requires data from the original retail discs to play. If you're interested in checking out the technology behind Unreal Tournament 2003, you can "emerge ut2003-demo" to get the playable demo.
+</longdescription>
+</pkgmetadata>
diff --git a/games-fps/ut2003-bonuspack-cm/ut2003-bonuspack-cm-1.ebuild b/games-fps/ut2003-bonuspack-cm/ut2003-bonuspack-cm-1.ebuild
new file mode 100644
index 000000000000..56ad68474614
--- /dev/null
+++ b/games-fps/ut2003-bonuspack-cm/ut2003-bonuspack-cm-1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit games
+
+IUSE=""
+DESCRIPTION="Community Bonus Pack for UT2003"
+HOMEPAGE="https://liandri.beyondunreal.com/Unreal_Tournament_2003"
+SRC_URI="https://ut.rushbase.net/beyondunreal/mods/cbp2003.zip"
+
+LICENSE="ut2003"
+SLOT="1"
+KEYWORDS="~x86"
+RESTRICT="mirror strip"
+
+RDEPEND="games-fps/ut2003"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+dir=${GAMES_PREFIX_OPT}/ut2003
+Ddir=${D}/${dir}
+
+src_unpack() {
+ unzip -qq "${DISTDIR}"/${A} || die
+}
+
+src_install() {
+ for i in Animations Help Music Maps StaticMeshes Textures System
+ do
+ mkdir -p "${Ddir}"/${i} || die
+ done
+ games_umod_unpack CBP2003.ut2mod
+ rm "${Ddir}/Readme.txt" "${Ddir}/cbp installer logo1.bmp"
+ prepgamesdirs
+}