summaryrefslogtreecommitdiff
path: root/games-fps/rtcw
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/rtcw')
-rw-r--r--games-fps/rtcw/Manifest5
-rw-r--r--games-fps/rtcw/files/wolf-ded.rc24
-rw-r--r--games-fps/rtcw/metadata.xml11
-rw-r--r--games-fps/rtcw/rtcw-1.41b.ebuild94
4 files changed, 134 insertions, 0 deletions
diff --git a/games-fps/rtcw/Manifest b/games-fps/rtcw/Manifest
new file mode 100644
index 000000000000..07c3ea36bb88
--- /dev/null
+++ b/games-fps/rtcw/Manifest
@@ -0,0 +1,5 @@
+AUX wolf-ded.rc 466 BLAKE2B 44e446448d1e21fed0e16808c6d7edaa67a237ccd992db6697a407ad88a20eb6b0fd0d8d22bd765e8cdaa165166a93d184acd6db34c0f7b06c7fe7de08fc3f08 SHA512 f949364731a608f397228db8f1b6753c6b307c32ded4330cfd19d76b1378317ab3f0b87f9db0435c255befd5cc5b1bcc37fa6af472b55f757e02b29f74a4645e
+DIST wolf-linux-1.41b.x86.run 73940068 BLAKE2B 252c2fe5028e8325481508fb2b1f944302895faf96f57f933092336899f10b29d4676f299072e852a4c57d20186bd14d0fe0aa780eba063f78881c4616d7f09c SHA512 8c018bcdeca5b14fe1b8c35f46031416978b27b57a38897fa5b1b0c26fbf3ab6f44c22582223ad98a695a793ba1444a2e092beee687e835a279a12121422e93f
+DIST wolf-linux-GOTY-maps.x86.run 51930759 BLAKE2B a675208035fd826b154c27cf9c77082bb0b69681725dfe9255e1a4cd2572ffc3db2b8998a7c7e04a4b423720d73d40317ff5ae07a121e979d5c707abf1cdd631 SHA512 85f334f75d538bb68c7507d36600b433b0ab0c92572c8e8c022eaeb8783fc72d56ff39ee0ee9eb3272ab09025bca56cca70b077b7e7b02a38cd556fb9f425dcc
+EBUILD rtcw-1.41b.ebuild 2771 BLAKE2B e00e1b7852e9ced1b4c5433520eba439cbd642c619f05f0f451a90678e7702b870b6644598dcf98d1bd31dcb7004ee88351cddca7d018059218870985aac3de6 SHA512 c9797beabed04ab34f4621f1a90d856a97bdb3c95fb9dc1d560159ab9dc754f35152fce972d93fb946c371ba9b9e2306642b87734482fde77fd21513771fafcf
+MISC metadata.xml 1048 BLAKE2B 25a54f490819a3e31dcdccbb907f95741721342654f362881021a8d4690aa2a97f5bd48568072286a67cd76fe382d1805f778af2bc9f60cbb8a38668262b14fd SHA512 9fe9d74cb94a07ba0b87c28ee050135e608ccae13e70aa8332e10adb5f2c11d7b86618c2c6a9824ccfe54425439f44827ebf85dbcf8add66178e538e81eb13a7
diff --git a/games-fps/rtcw/files/wolf-ded.rc b/games-fps/rtcw/files/wolf-ded.rc
new file mode 100644
index 000000000000..3f7bf956c10a
--- /dev/null
+++ b/games-fps/rtcw/files/wolf-ded.rc
@@ -0,0 +1,24 @@
+#!/sbin/openrc-run
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting RTCW dedicated server..."
+ screen -A -m -d -S rtcw su - dedicated -c GENTOO_DIR/startwolfded
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping RTCW dedicated server..."
+ kill `screen -list | grep rtcw | awk -F . '{ print $1 }' | sed -e s/.//`
+ eend $?
+
+}
+
+status() {
+ screen -list | grep rtcwded
+}
diff --git a/games-fps/rtcw/metadata.xml b/games-fps/rtcw/metadata.xml
new file mode 100644
index 000000000000..4c558817e05b
--- /dev/null
+++ b/games-fps/rtcw/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+<longdescription>
+Return to Castle Wolfenstein is a first-person 3-D shooter based loosely on the original Wolfenstein series by id software. The game takes place in Europe during World War II. In the single player game, you play as a US military special operative sent behind enemy lines to stop the Nazi studies into the supernatural and the occult. The multi-player game is a team-based, goal-oriented series of missions and allows you to play as either the Axis or the Allies. There are several classes of characters you can play, each with their own special abilities and weapon choices. The port to Linux was done by TTimo of id software and is an unsupported binary release. This game is commercial software and requires data from the retail Windows version to play.
+</longdescription>
+</pkgmetadata>
diff --git a/games-fps/rtcw/rtcw-1.41b.ebuild b/games-fps/rtcw/rtcw-1.41b.ebuild
new file mode 100644
index 000000000000..2cd098cbd9cf
--- /dev/null
+++ b/games-fps/rtcw/rtcw-1.41b.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils unpacker games
+
+DESCRIPTION="Return to Castle Wolfenstein - Long awaited sequel to Wolfenstein 3D"
+HOMEPAGE="http://games.activision.com/games/wolfenstein/"
+SRC_URI="mirror://idsoftware/wolf/linux/wolf-linux-GOTY-maps.x86.run
+ mirror://idsoftware/wolf/linux/wolf-linux-${PV}.x86.run"
+# mirror://3dgamers/returnwolfenstein/wolf-linux-${PV}.x86.run
+
+LICENSE="RTCW GPL-2" # gpl for init script bug #425944
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="opengl dedicated"
+RESTRICT="strip mirror"
+
+UIDEPEND="x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXau[abi_x86_32(-)]
+ x11-libs/libXdmcp[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ virtual/opengl[abi_x86_32(-)]"
+RDEPEND="sys-libs/glibc
+ sys-libs/lib-compat
+ dedicated? ( app-misc/screen )
+ !dedicated? ( ${UIDEPEND} )
+ opengl? ( ${UIDEPEND} )"
+
+S=${WORKDIR}
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+QA_PREBUILT="${dir:1}/* ${dir:1}/pb/* ${dir:1}/main/*"
+
+src_install() {
+ insinto "${dir}"
+ doins -r main Docs pb
+
+ exeinto "${dir}"
+ doexe bin/Linux/x86/*.x86 openurl.sh
+
+ games_make_wrapper rtcwmp ./wolf.x86 "${dir}" "${dir}"
+ games_make_wrapper rtcwsp ./wolfsp.x86 "${dir}" "${dir}"
+ # work around buggy video driver (bug #326837)
+ sed -i \
+ -e 's/^exec /__GL_ExtensionStringVersion=17700 exec /' \
+ "${D}/${GAMES_BINDIR}/rtcwsp" \
+ || die
+
+ if use dedicated; then
+ games_make_wrapper wolf-ded ./wolfded.x86 "${dir}" "${dir}"
+ newinitd "${FILESDIR}"/wolf-ded.rc wolf-ded
+ sed -i \
+ -e "s:GENTOO_DIR:${dir}:" \
+ "${D}"/etc/init.d/wolf-ded \
+ || die
+ fi
+
+ insinto ${dir}
+ doins WolfMP.xpm WolfSP.xpm QUICKSTART CHANGES RTCW-README-1.4.txt
+ doicon WolfMP.xpm WolfSP.xpm
+
+ prepgamesdirs
+ make_desktop_entry rtcwmp "Return to Castle Wolfenstein (MP)" WolfMP
+ make_desktop_entry rtcwsp "Return to Castle Wolfenstein (SP)" WolfSP
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ ewarn "There are two possible security bugs in this package, both causing a"
+ ewarn "denial of service. One affects the game when running a server, the"
+ ewarn "other when running as a client."
+ ewarn "For more information, see bug #82149."
+ echo
+ elog "You need to copy pak0.pk3, mp_pak0.pk3, mp_pak1.pk3, mp_pak2.pk3,"
+ elog "sp_pak1.pk3 and sp_pak2.pk3 from a Window installation into ${dir}/main/"
+ elog
+ elog "To play the game run:"
+ elog " rtcwsp (single-player)"
+ elog " rtcwmp (multi-player)"
+ elog
+ if use dedicated
+ then
+ elog "To start a dedicated server run:"
+ elog " /etc/init.d/wolf-ded start"
+ elog
+ elog "To run the dedicated server at boot, type:"
+ elog " rc-update add wolf-ded default"
+ elog
+ elog "The dedicated server is started under the ${GAMES_USER_DED} user account"
+ echo
+ fi
+}