summaryrefslogtreecommitdiff
path: root/games-fps/quake1-teamfortress/quake1-teamfortress-2.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/quake1-teamfortress/quake1-teamfortress-2.9.ebuild')
-rw-r--r--games-fps/quake1-teamfortress/quake1-teamfortress-2.9.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/games-fps/quake1-teamfortress/quake1-teamfortress-2.9.ebuild b/games-fps/quake1-teamfortress/quake1-teamfortress-2.9.ebuild
new file mode 100644
index 000000000000..19e52511fc51
--- /dev/null
+++ b/games-fps/quake1-teamfortress/quake1-teamfortress-2.9.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="The classic Team Fortress Quake World mod"
+HOMEPAGE="http://www.planetfortress.com/teamfortress/"
+SRC_URI="mirror://gentoo/tf28.zip
+ mirror://gentoo/tf29qw.zip"
+
+LICENSE="quake1-teamfortress"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}
+
+src_unpack() {
+ echo ">>> Unpacking tf28.zip to ${PWD}"
+ unzip -qoL "${DISTDIR}"/tf28.zip || die "unpacking tf28.zip failed"
+ cd fortress
+ echo ">>> Unpacking tf29qw.zip to ${PWD}"
+ unzip -qoL "${DISTDIR}"/tf29qw.zip || die "unpacking tf29qw.zip failed"
+
+ edos2unix $(find . -name '*.txt' -o -name '*.cfg')
+ mv server.cfg server.example.cfg
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}/quake1"
+ doins -r *
+ prepgamesdirs
+}