summaryrefslogtreecommitdiff
path: root/games-fps/gzdoom/gzdoom-4.1.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/gzdoom/gzdoom-4.1.3.ebuild')
-rw-r--r--games-fps/gzdoom/gzdoom-4.1.3.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/games-fps/gzdoom/gzdoom-4.1.3.ebuild b/games-fps/gzdoom/gzdoom-4.1.3.ebuild
new file mode 100644
index 000000000000..d3d5f880537b
--- /dev/null
+++ b/games-fps/gzdoom/gzdoom-4.1.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils desktop xdg
+
+DESCRIPTION="A modder-friendly OpenGL source port based on the DOOM engine"
+HOMEPAGE="https://zdoom.org"
+SRC_URI="https://github.com/coelckers/${PN}/archive/g${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD BZIP2 DUMB-0.9.3 GPL-3 LGPL-3 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="fluidsynth gtk gtk2 +openal openmp"
+
+DEPEND="
+ media-libs/libsdl2[opengl]
+ sys-libs/zlib
+ virtual/jpeg:0
+ gtk? (
+ gtk2? ( x11-libs/gtk+:2 )
+ !gtk2? ( x11-libs/gtk+:3 )
+ )"
+RDEPEND="
+ ${DEPEND}
+ fluidsynth? ( media-sound/fluidsynth:= )
+ openal? (
+ media-libs/libsndfile
+ media-libs/openal
+ media-sound/mpg123
+ )"
+
+S="${WORKDIR}/${PN}-g${PV}"
+PATCHES="${FILESDIR}/${P}-fluidsynth2.patch"
+
+src_prepare() {
+ rm -rf docs/licenses || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_DOCS_PATH="${EPREFIX}/usr/share/doc/${PF}"
+ -DINSTALL_PK3_PATH="${EPREFIX}/usr/share/doom"
+ -DDYN_FLUIDSYNTH=OFF
+ -DDYN_OPENAL=OFF
+ -DDYN_SNDFILE=OFF
+ -DDYN_MPG123=OFF
+ -DNO_GTK="$(usex !gtk)"
+ -DNO_OPENAL="$(usex !openal)"
+ -DNO_OPENMP="$(usex !openmp)"
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ newicon src/posix/zdoom.xpm "${PN}.xpm"
+ make_desktop_entry "${PN}" "GZDoom" "${PN}" "Game;ActionGame"
+ cmake-utils_src_install
+}