summaryrefslogtreecommitdiff
path: root/games-fps/freedm-data/freedm-data-0.11.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/freedm-data/freedm-data-0.11.3.ebuild')
-rw-r--r--games-fps/freedm-data/freedm-data-0.11.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/games-fps/freedm-data/freedm-data-0.11.3.ebuild b/games-fps/freedm-data/freedm-data-0.11.3.ebuild
new file mode 100644
index 000000000000..43ac7804c6a0
--- /dev/null
+++ b/games-fps/freedm-data/freedm-data-0.11.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Game resources for FreeDM"
+HOMEPAGE="https://freedoom.github.io"
+SRC_URI="https://github.com/freedoom/freedoom/releases/download/v${PV}/freedm-${PV}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="app-arch/unzip"
+
+S="${WORKDIR}/freedm-${PV}"
+
+DOOMWADPATH=/usr/share/doom
+
+src_install() {
+ insinto ${DOOMWADPATH}
+ doins freedm.wad
+ dodoc CREDITS.txt README.html
+}
+
+pkg_postinst() {
+ elog "FreeDM WAD file installed into ${DOOMWADPATH} directory."
+}