summaryrefslogtreecommitdiff
path: root/games-fps/doom3-lms/doom3-lms-4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/doom3-lms/doom3-lms-4.ebuild')
-rw-r--r--games-fps/doom3-lms/doom3-lms-4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/games-fps/doom3-lms/doom3-lms-4.ebuild b/games-fps/doom3-lms/doom3-lms-4.ebuild
new file mode 100644
index 000000000000..c931cd3f1b92
--- /dev/null
+++ b/games-fps/doom3-lms/doom3-lms-4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MOD_DESC="add co-op support or play against swarms of monsters"
+MOD_NAME="Last Man Standing"
+MOD_DIR="lms4"
+
+inherit games games-mods
+
+HOMEPAGE="https://www.doom3coop.com"
+SRC_URI="LastManStandingCoop4Multiplatform.zip"
+
+LICENSE="GameFront"
+KEYWORDS="~amd64 ~x86"
+IUSE="dedicated opengl"
+RESTRICT="fetch bindist"
+
+pkg_nofetch() {
+ elog "Please download ${SRC_URI} from:"
+ elog "http://www.moddb.com/mods/last-man-standing-coop/downloads"
+ elog "and move it to ${DISTDIR}"
+}
+
+src_prepare() {
+ cd ${MOD_DIR} || die
+ rm -f *.{bat,url} game_lms40{0,2}.pk4
+}