summaryrefslogtreecommitdiff
path: root/games-fps/doom3-eventhorizon/doom3-eventhorizon-1.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/doom3-eventhorizon/doom3-eventhorizon-1.3.ebuild')
-rw-r--r--games-fps/doom3-eventhorizon/doom3-eventhorizon-1.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/games-fps/doom3-eventhorizon/doom3-eventhorizon-1.3.ebuild b/games-fps/doom3-eventhorizon/doom3-eventhorizon-1.3.ebuild
new file mode 100644
index 000000000000..add575517592
--- /dev/null
+++ b/games-fps/doom3-eventhorizon/doom3-eventhorizon-1.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MOD_DESC="single-player mission based on the Event Horizon film"
+MOD_NAME="Event Horizon"
+MOD_DIR="eventhorizon"
+
+inherit games games-mods
+
+HOMEPAGE="http://www.gamefront.com/files/10716974"
+SRC_URI="event_horizon_xv_${PV}.zip"
+
+LICENSE="all-rights-reserved"
+KEYWORDS="~amd64 ~x86"
+IUSE="dedicated opengl"
+RESTRICT="fetch mirror"
+
+pkg_nofetch() {
+ einfo
+ einfo "Please download \"${SRC_URI}\" from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move/link it to \"${DISTDIR}\""
+ einfo
+}
+
+src_prepare() {
+ mv -f event_horizon* ${MOD_DIR} || die
+}