summaryrefslogtreecommitdiff
path: root/games-fps/doom3-chextrek/doom3-chextrek-0.52.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/doom3-chextrek/doom3-chextrek-0.52.ebuild')
-rw-r--r--games-fps/doom3-chextrek/doom3-chextrek-0.52.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/games-fps/doom3-chextrek/doom3-chextrek-0.52.ebuild b/games-fps/doom3-chextrek/doom3-chextrek-0.52.ebuild
new file mode 100644
index 000000000000..2f9b99a7b4fb
--- /dev/null
+++ b/games-fps/doom3-chextrek/doom3-chextrek-0.52.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MOD_DESC="Green slimeballs mod for kids"
+MOD_NAME="Chex Trek: Beyond the Quest"
+MOD_DIR="chextrek"
+MOD_ICON="flem.ico"
+
+inherit games-mods
+
+HOMEPAGE="https://www.moddb.com/mods/chex-trek-beyond-the-quest"
+SRC_URI="chextrek_beta_${PV/.}.zip"
+
+LICENSE="GameFront"
+KEYWORDS="~amd64 ~x86"
+IUSE="dedicated opengl"
+RESTRICT="fetch bindist"
+
+pkg_nofetch() {
+ elog "Please download ${SRC_URI} from:"
+ elog "https://www.moddb.com/mods/chex-trek-beyond-the-quest/downloads/chex-trek-beta-052"
+ elog "and move it to ${DISTDIR}"
+}
+
+src_prepare() {
+ mv -f chextrek_beta* ${MOD_DIR} || die
+}
+
+pkg_postinst() {
+ games-mods_pkg_postinst
+
+ elog "Press 'E' to open doors in the game."
+ elog "Press 'M' to toggle the map."
+}