summaryrefslogtreecommitdiff
path: root/games-fps/doom-data
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/doom-data')
-rw-r--r--games-fps/doom-data/doom-data-1.9.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/games-fps/doom-data/doom-data-1.9.ebuild b/games-fps/doom-data/doom-data-1.9.ebuild
new file mode 100644
index 000000000000..73c1f9cd04d5
--- /dev/null
+++ b/games-fps/doom-data/doom-data-1.9.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="The IWAD used by the shareware version of Doom"
+HOMEPAGE="http://www.idsoftware.com"
+SRC_URI="http://distro.ibiblio.org/pub/linux/distributions/slitaz/sources/packages/d/doom1.wad"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+S="${DISTDIR}"
+
+DOOMWADPATH="/usr/share/doom"
+
+src_install() {
+ insinto ${DOOMWADPATH}
+ doins doom1.wad
+}
+
+pkg_postinst() {
+ elog "Doom WAD file installed into the ${DOOMWADPATH} directory."
+ elog "A Doom engine is required in order to play the doom1.wad file."
+}