summaryrefslogtreecommitdiff
path: root/games-fps/avp/avp-20150214-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/avp/avp-20150214-r1.ebuild')
-rw-r--r--games-fps/avp/avp-20150214-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/games-fps/avp/avp-20150214-r1.ebuild b/games-fps/avp/avp-20150214-r1.ebuild
new file mode 100644
index 000000000000..7a41b588eaad
--- /dev/null
+++ b/games-fps/avp/avp-20150214-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils cmake-utils
+
+DESCRIPTION="Linux port of Aliens vs Predator"
+HOMEPAGE="http://www.icculus.org/avp/"
+SRC_URI="http://www.icculus.org/avp/files/${P}.tar.gz"
+
+LICENSE="AvP"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ media-libs/libsdl[video,joystick,opengl]
+ media-libs/openal"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+CMAKE_BUILD_TYPE=Release
+
+src_configure() {
+ local mycmakeargs=(
+ "-DCMAKE_VERBOSE_MAKEFILE=TRUE"
+ -DSDL_TYPE=SDL
+ -DOPENGL_TYPE=OPENGL
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ dobin "${BUILD_DIR}/${PN}"
+ dodoc README
+}
+
+pkg_postinst() {
+ elog "Please follow the instructions in /usr/share/doc/${PF}"
+ elog "to install the rest of the game."
+}