summaryrefslogtreecommitdiff
path: root/games-engines/openxcom/openxcom-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-engines/openxcom/openxcom-9999.ebuild')
-rw-r--r--games-engines/openxcom/openxcom-9999.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/games-engines/openxcom/openxcom-9999.ebuild b/games-engines/openxcom/openxcom-9999.ebuild
deleted file mode 100644
index 7726841e5584..000000000000
--- a/games-engines/openxcom/openxcom-9999.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit cmake-utils gnome2-utils git-r3
-
-DESCRIPTION="An open-source reimplementation of the popular UFO: Enemy Unknown"
-HOMEPAGE="https://openxcom.org/"
-EGIT_REPO_URI="https://github.com/SupSuper/OpenXcom.git"
-
-LICENSE="GPL-3+ CC-BY-SA-4.0"
-SLOT="0"
-KEYWORDS=""
-IUSE="doc"
-
-RDEPEND=">=dev-cpp/yaml-cpp-0.5.1
- media-libs/libsdl[opengl,video]
- media-libs/sdl-gfx
- media-libs/sdl-image[png]
- media-libs/sdl-mixer[flac,mikmod,vorbis]"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )"
-
-DOCS=( README.md )
-
-src_compile() {
- use doc && cmake-utils_src_compile doxygen
- cmake-utils_src_compile
-}
-
-src_install() {
- cmake-utils_src_install
- use doc && dodoc -r "${CMAKE_BUILD_DIR}"/docs/html/*
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
- echo
- elog "In order to play you need copy GEODATA, GEOGRAPH, MAPS, ROUTES, SOUND,"
- elog "TERRAIN, UFOGRAPH, UFOINTRO, UNITS folders from original X-COM game to"
- elog "/usr/share/${PN}/UFO"
- echo
- elog "If you want to play the TFTD mod, you need to copy ANIMS, FLOP_INT,"
- elog "GEODATA, GEOGRAPH, MAPS, ROUTES, SOUND, TERRAIN, UFOGRAPH, UNITS folders"
- elog "from the original Terror from the Deep game to"
- elog "/usr/share/${PN}/TFTD"
- echo
- elog "If you need or want text in some language other than english, download:"
- elog "https://openxcom.org/translations/latest.zip and uncompress it in"
- elog "/usr/share/${PN}/common/Language"
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}