summaryrefslogtreecommitdiff
path: root/games-engines/openmw
diff options
context:
space:
mode:
Diffstat (limited to 'games-engines/openmw')
-rw-r--r--games-engines/openmw/Manifest4
-rw-r--r--games-engines/openmw/files/openmw-0.43.0-qt-5.11b3.patch81
-rw-r--r--games-engines/openmw/metadata.xml26
-rw-r--r--games-engines/openmw/openmw-0.43.0-r1.ebuild132
4 files changed, 243 insertions, 0 deletions
diff --git a/games-engines/openmw/Manifest b/games-engines/openmw/Manifest
new file mode 100644
index 000000000000..9bc9c7baf7b9
--- /dev/null
+++ b/games-engines/openmw/Manifest
@@ -0,0 +1,4 @@
+AUX openmw-0.43.0-qt-5.11b3.patch 2842 BLAKE2B 29bf75b29144c6a9eadb316998b16bf2b2e492624d70d7a2a3578b67ec3446b2359642dc13c242131c803f3e300af3d0f0dad09f19f9462f2b42beccc0d84c87 SHA512 1cc4bc7c9fdaadf829ab8526d9fbd72a0058628293b133e701bd187f80ed234e7951d4cc2ec07fdcb521d685ff1471ef27b78b5db77156bbecc2165b653f7897
+DIST openmw-0.43.0.tar.gz 5023421 BLAKE2B c99e3a23b22b642dea9e8f2d9414e00aa6a05c4331a9715882465781caca60cd857675d87079bafc3596783e257213bec9d6f1f4e78a3d795e973fb1d895811e SHA512 e902dd2274c05838bb1171f07d7a673fc7b85d1290a9e01c8ab89f1c279bd236332ecdc0f2b7944ec7209a0e6022ff472639b5724bf26904e3a2d338c7be401a
+EBUILD openmw-0.43.0-r1.ebuild 3291 BLAKE2B e35859cbdca3aea7d6ac5cead05681d090c9164905958c92ad5c7c9a046e3eb345b7fe03b68b123650d2f2ec239ffd50be57acfa794a145b831c17a49b1b1dd9 SHA512 bc8393f838424342ff29fea1b4bdfbfe5082edcbadc256a9771cfaf2139464d1e97ac7bdb57de61e8dd15edd61c97e3af10a7b649bd163a44daceeea8ae197f0
+MISC metadata.xml 1044 BLAKE2B 132bf7783f4cdac33cfb9bffac4e8a0baf7380f8bb91b262c087ebab4848e6fc97dbac258d600836f1d447536077f063d0dc0ca7348179a61310806f5862ecfe SHA512 c47622fc66013a7c61b1f865619a77707b296b051df54bd75048073b6b5875d97fb300d490a5aba923cc369566ffb5f3dbab16451d1bf48f5f91de18ee7c2116
diff --git a/games-engines/openmw/files/openmw-0.43.0-qt-5.11b3.patch b/games-engines/openmw/files/openmw-0.43.0-qt-5.11b3.patch
new file mode 100644
index 000000000000..85b290e660ba
--- /dev/null
+++ b/games-engines/openmw/files/openmw-0.43.0-qt-5.11b3.patch
@@ -0,0 +1,81 @@
+From 2c9d46a60bd8d35f132cb106e5255d590b13640b Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Tue, 17 Apr 2018 23:03:56 +0200
+Subject: [PATCH] Fix build with Qt 5.11_beta3 (dropping qt5_use_modules)
+
+---
+ apps/launcher/CMakeLists.txt | 2 +-
+ apps/opencs/CMakeLists.txt | 2 +-
+ apps/wizard/CMakeLists.txt | 2 +-
+ components/CMakeLists.txt | 2 +-
+ extern/osgQt/CMakeLists.txt | 2 +-
+ 5 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/apps/launcher/CMakeLists.txt b/apps/launcher/CMakeLists.txt
+index aec8c2533..99e7b4daa 100644
+--- a/apps/launcher/CMakeLists.txt
++++ b/apps/launcher/CMakeLists.txt
+@@ -106,7 +106,7 @@ if (DESIRED_QT_VERSION MATCHES 4)
+ target_link_libraries(openmw-launcher ${QT_QTMAIN_LIBRARY})
+ endif(WIN32)
+ else()
+- qt5_use_modules(openmw-launcher Widgets Core)
++ target_link_libraries(openmw-launcher Qt5::Widgets Qt5::Core)
+ endif()
+
+ if (BUILD_WITH_CODE_COVERAGE)
+diff --git a/apps/opencs/CMakeLists.txt b/apps/opencs/CMakeLists.txt
+index b9279bf91..f07b518a9 100644
+--- a/apps/opencs/CMakeLists.txt
++++ b/apps/opencs/CMakeLists.txt
+@@ -246,7 +246,7 @@ if (DESIRED_QT_VERSION MATCHES 4)
+ target_link_libraries(openmw-cs ${QT_QTMAIN_LIBRARY})
+ endif()
+ else()
+- qt5_use_modules(openmw-cs Widgets Core Network OpenGL)
++ target_link_libraries(openmw-cs Qt5::Widgets Qt5::Core Qt5::Network Qt5::OpenGL)
+ endif()
+
+ if (WIN32)
+diff --git a/apps/wizard/CMakeLists.txt b/apps/wizard/CMakeLists.txt
+index 5f7338e52..8d97bbcbf 100644
+--- a/apps/wizard/CMakeLists.txt
++++ b/apps/wizard/CMakeLists.txt
+@@ -118,7 +118,7 @@ if (DESIRED_QT_VERSION MATCHES 4)
+ target_link_libraries(openmw-wizard ${QT_QTMAIN_LIBRARY})
+ endif()
+ else()
+- qt5_use_modules(openmw-wizard Widgets Core)
++ target_link_libraries(openmw-wizard Qt5::Widgets Qt5::Core)
+ endif()
+
+ if (OPENMW_USE_UNSHIELD)
+diff --git a/components/CMakeLists.txt b/components/CMakeLists.txt
+index 8256f1443..ecb844a9b 100644
+--- a/components/CMakeLists.txt
++++ b/components/CMakeLists.txt
+@@ -216,7 +216,7 @@ if (USE_QT)
+ ${QT_QTCORE_LIBRARY}
+ ${QT_QTGUI_LIBRARY})
+ else()
+- qt5_use_modules(components Widgets Core)
++ target_link_libraries(components Qt5::Widgets Qt5::Core)
+ endif()
+ endif()
+
+diff --git a/extern/osgQt/CMakeLists.txt b/extern/osgQt/CMakeLists.txt
+index 3bd08a390..78a4e6034 100644
+--- a/extern/osgQt/CMakeLists.txt
++++ b/extern/osgQt/CMakeLists.txt
+@@ -12,7 +12,7 @@ if (DESIRED_QT_VERSION MATCHES 4)
+ include(${QT_USE_FILE})
+ target_link_libraries(${OSGQT_LIBRARY} ${QT_QTCORE_LIBRARY} ${QT_QTOPENGL_LIBRARY})
+ else()
+- qt5_use_modules(${OSGQT_LIBRARY} Core OpenGL)
++ target_link_libraries(${OSGQT_LIBRARY} Qt5::Core Qt5::OpenGL)
+ endif()
+
+ link_directories(${CMAKE_CURRENT_BINARY_DIR})
+--
+2.17.0
+
diff --git a/games-engines/openmw/metadata.xml b/games-engines/openmw/metadata.xml
new file mode 100644
index 000000000000..191124d297e1
--- /dev/null
+++ b/games-engines/openmw/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <use>
+ <flag name="devtools">Install development tools like
+ bsatool, esmtool and opencs.</flag>
+ </use>
+ <upstream>
+ <changelog>https://github.com/OpenMW/openmw/releases</changelog>
+ <doc lang="en">https://wiki.openmw.org</doc>
+ <bugs-to>https://bugs.openmw.org/</bugs-to>
+ <remote-id type="github">OpenMW/openmw</remote-id>
+ </upstream>
+ <longdescription lang="en">
+ OpenMW is a new and modern engine based on the one that runs the 2002
+ open-world RPG Morrowind. The engine (OpenMW) will come with its own
+ editor (OpenCS) which will allow the user to edit or create their own
+ games. Both OpenCS and OpenMW are written from scratch and aren’t
+ made to support any third party programs the original Morrowind
+ engine uses to improve its functionality.
+ </longdescription>
+</pkgmetadata>
diff --git a/games-engines/openmw/openmw-0.43.0-r1.ebuild b/games-engines/openmw/openmw-0.43.0-r1.ebuild
new file mode 100644
index 000000000000..0efb2c196763
--- /dev/null
+++ b/games-engines/openmw/openmw-0.43.0-r1.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils gnome2-utils readme.gentoo-r1
+
+DESCRIPTION="Open source reimplementation of TES III: Morrowind"
+HOMEPAGE="https://openmw.org/"
+SRC_URI="https://github.com/OpenMW/openmw/archive/${P}.tar.gz"
+
+LICENSE="GPL-3 MIT BitstreamVera ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc devtools +qt5"
+
+RDEPEND="
+ dev-games/mygui
+ || (
+ (
+ >=dev-games/openscenegraph-3.5.5[ffmpeg,jpeg,png,sdl,svg,truetype,zlib]
+ dev-games/openscenegraph-qt
+ )
+ <dev-games/openscenegraph-3.5.5[ffmpeg,jpeg,png,qt5,sdl,svg,truetype,zlib]
+ )
+ dev-libs/boost:=[threads]
+ dev-libs/tinyxml[stl]
+ media-libs/libsdl2[joystick,opengl,video,X]
+ media-libs/openal
+ media-video/ffmpeg:=
+ >=sci-physics/bullet-2.86
+ virtual/opengl
+ qt5? (
+ app-arch/unshield
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtopengl:5
+ dev-qt/qtwidgets:5
+ )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen[doc] dev-python/sphinx )"
+
+S="${WORKDIR}/${PN}-${P}"
+
+PATCHES=( "${FILESDIR}/${P}-qt-5.11b3.patch" )
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # We don't install license files
+ sed -e '/LICDIR/d' \
+ -i CMakeLists.txt || die
+ # Use the system tinyxml headers
+ sed -e 's/"tinyxml.h"/<tinyxml.h>/g' \
+ -e 's/"tinystr.h"/<tinystr.h>/g' \
+ -i extern/oics/ICSPrerequisites.h || die
+}
+
+src_configure() {
+ use devtools && ! use qt5 && \
+ elog "'qt5' USE flag is disabled, 'openmw-cs' will not be installed"
+
+ local mycmakeargs=(
+ -DBUILD_BSATOOL=$(usex devtools)
+ -DBUILD_DOCS=$(usex doc)
+ -DBUILD_ESMTOOL=$(usex devtools)
+ -DBUILD_LAUNCHER=$(usex qt5)
+ -DBUILD_NIFTEST=$(usex devtools)
+ -DBUILD_OPENCS=$(usex devtools $(usex qt5))
+ -DBUILD_WIZARD=$(usex qt5)
+ -DBUILD_UNITTESTS=OFF
+ -DGLOBAL_DATA_PATH=/usr/share
+ -DICONDIR="/usr/share/icons/hicolor/256x256/apps"
+ -DMORROWIND_DATA_FILES="/usr/share/morrowind-data"
+ -DUSE_SYSTEM_TINYXML=ON
+ -DDESIRED_QT_VERSION=5
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ if use doc ; then
+ cmake-utils_src_compile doc
+ find "${CMAKE_BUILD_DIR}"/docs/Doxygen/html \
+ -name '*.md5' -type f -delete || die
+ HTML_DOCS=( "${CMAKE_BUILD_DIR}"/docs/Doxygen/html/. )
+ fi
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ local DOC_CONTENTS="
+ You need the original Morrowind data files. If you haven't
+ installed them yet, you can install them straight via the
+ installation wizard which is the officially supported method
+ (either by using the launcher or by calling 'openmw-wizard'
+ directly).\n"
+
+ if ! use qt5; then
+ local DOC_CONTENTS+="\n\n
+ USE flag 'qt5' is disabled, 'openmw-launcher' and
+ 'openmw-wizard' are not available. You are on your own for
+ making the Morrowind data files available and pointing
+ openmw at them.\n\n
+ Additionally; you must import the Morrowind.ini file before
+ running openmw with the Morrowind data files for the first
+ time. Typically this can be done like so:\n\n
+ \t mkdir -p ~/.config/openmw\n
+ \t openmw-iniimporter /path/to/Morrowind.ini ~/.config/openmw/openmw.cfg"
+ fi
+
+ readme.gentoo_create_doc
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}