summaryrefslogtreecommitdiff
path: root/games-emulation/sameboy-jg
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/sameboy-jg')
-rw-r--r--games-emulation/sameboy-jg/Manifest4
-rw-r--r--games-emulation/sameboy-jg/metadata.xml21
-rw-r--r--games-emulation/sameboy-jg/sameboy-jg-0.15.8.ebuild49
-rw-r--r--games-emulation/sameboy-jg/sameboy-jg-9999.ebuild49
4 files changed, 123 insertions, 0 deletions
diff --git a/games-emulation/sameboy-jg/Manifest b/games-emulation/sameboy-jg/Manifest
new file mode 100644
index 000000000000..2f1a1bed7356
--- /dev/null
+++ b/games-emulation/sameboy-jg/Manifest
@@ -0,0 +1,4 @@
+DIST sameboy-0.15.8.tar.bz2 3002961 BLAKE2B 5eacbc82d8c93ee85b774c554b3d3750088e8a4219d5b04daa9e6db0c70923ef823befc12831382a27ee007f117fddcfe35ff3549d7684b8587db9ffc486ccd6 SHA512 9074dfcbf400fe51e605ef0200f6ea8483650d605ab19177089c0e60f9996c15f265c5dec5fd0e6651392c9a9515e8380499e00bac837bb645220cd6ffa9c870
+EBUILD sameboy-jg-0.15.8.ebuild 953 BLAKE2B 80f8f6a3128b07075774bf2dac2ee6626c6c5a9bb46198d0a80b1108d36256c4eea5798e3ad2f58ab0201e3df4e80d86e69c1323e53f792c2464eb7684f4d94b SHA512 03a56fae6b8803163f621be338f6a71bc924581305afae0f4b1a0c634749ebac465769e74b074f055ccc1b77f80e21051e2ebea116eea0270728663d09c2bd7b
+EBUILD sameboy-jg-9999.ebuild 953 BLAKE2B 80f8f6a3128b07075774bf2dac2ee6626c6c5a9bb46198d0a80b1108d36256c4eea5798e3ad2f58ab0201e3df4e80d86e69c1323e53f792c2464eb7684f4d94b SHA512 03a56fae6b8803163f621be338f6a71bc924581305afae0f4b1a0c634749ebac465769e74b074f055ccc1b77f80e21051e2ebea116eea0270728663d09c2bd7b
+MISC metadata.xml 725 BLAKE2B 77295d1bcc5ed31dfc5d162fc2f88e03954fa5552e6ccb688e286c82c68a427edda2717509b3503325d79b5c1ffebc943e4f5ad4da4f24e6d9b9e9dd66b69fb5 SHA512 1c37d417d50220e6201719509c9f66be97d13482846a111728e1020fec3215f55309a48b63d1a13ff66d9c9976783cc767b6124d8888dc3792de7bdccb1d71af
diff --git a/games-emulation/sameboy-jg/metadata.xml b/games-emulation/sameboy-jg/metadata.xml
new file mode 100644
index 000000000000..3f127f5cbd75
--- /dev/null
+++ b/games-emulation/sameboy-jg/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>orbea@riseup.net</email>
+ <name>orbea</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ SameBoy is an extremely accurate, powerful and open source
+ Game Boy (DMG), Game Boy Color (CGB) and Super Game Boy (SGB)
+ emulator, written in portable C.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://gitlab.com/jgemu/sameboy/-/issues</bugs-to>
+ <remote-id type="gitlab">jgemu/sameboy</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-emulation/sameboy-jg/sameboy-jg-0.15.8.ebuild b/games-emulation/sameboy-jg/sameboy-jg-0.15.8.ebuild
new file mode 100644
index 000000000000..2a20f4b0419c
--- /dev/null
+++ b/games-emulation/sameboy-jg/sameboy-jg-0.15.8.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN=${PN%-*}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Jolly Good Port of SameBoy"
+HOMEPAGE="https://gitlab.com/jgemu/sameboy"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="1"
+
+DEPEND="
+ media-libs/jg:1=
+"
+RDEPEND="
+ ${DEPEND}
+ games-emulation/jgrf
+"
+BDEPEND="
+ >=dev-util/rgbds-0.6.0
+ virtual/pkgconfig
+"
+
+src_compile() {
+ emake -C jollygood \
+ CC="$(tc-getCC)" \
+ CC_FOR_BUILD="$(tc-getBUILD_CC)" \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ emake -C jollygood install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}
diff --git a/games-emulation/sameboy-jg/sameboy-jg-9999.ebuild b/games-emulation/sameboy-jg/sameboy-jg-9999.ebuild
new file mode 100644
index 000000000000..2a20f4b0419c
--- /dev/null
+++ b/games-emulation/sameboy-jg/sameboy-jg-9999.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN=${PN%-*}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Jolly Good Port of SameBoy"
+HOMEPAGE="https://gitlab.com/jgemu/sameboy"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="1"
+
+DEPEND="
+ media-libs/jg:1=
+"
+RDEPEND="
+ ${DEPEND}
+ games-emulation/jgrf
+"
+BDEPEND="
+ >=dev-util/rgbds-0.6.0
+ virtual/pkgconfig
+"
+
+src_compile() {
+ emake -C jollygood \
+ CC="$(tc-getCC)" \
+ CC_FOR_BUILD="$(tc-getBUILD_CC)" \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ emake -C jollygood install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}