summaryrefslogtreecommitdiff
path: root/games-emulation/ppsspp/ppsspp-1.15.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/ppsspp/ppsspp-1.15.4.ebuild')
-rw-r--r--games-emulation/ppsspp/ppsspp-1.15.4.ebuild74
1 files changed, 0 insertions, 74 deletions
diff --git a/games-emulation/ppsspp/ppsspp-1.15.4.ebuild b/games-emulation/ppsspp/ppsspp-1.15.4.ebuild
deleted file mode 100644
index 064e56772306..000000000000
--- a/games-emulation/ppsspp/ppsspp-1.15.4.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit flag-o-matic python-any-r1 xdg cmake
-
-DESCRIPTION="A PSP emulator written in C++"
-HOMEPAGE="https://www.ppsspp.org/
- https://github.com/hrydgard/ppsspp/"
-SRC_URI="https://github.com/hrydgard/${PN}/releases/download/v${PV}/${P}.tar.xz"
-
-LICENSE="Apache-2.0 BSD BSD-2 GPL-2 JSON MIT"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="discord qt5 test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- app-arch/snappy:=
- app-arch/zstd:=
- dev-libs/libzip:=
- media-libs/glew:=
- media-libs/libpng:=
- media-libs/libsdl2[joystick]
- media-video/ffmpeg:0/56.58.58
- sys-libs/zlib:=
- virtual/opengl
- qt5? (
- dev-qt/qtcore:5
- dev-qt/qtgui:5[-gles2-only]
- dev-qt/qtmultimedia:5[-gles2-only]
- dev-qt/qtopengl:5[-gles2-only]
- dev-qt/qtwidgets:5[-gles2-only]
- )
- !qt5? ( media-libs/libsdl2[X,opengl,sound,video] )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="${PYTHON_DEPS}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-CMakeLists-flags.patch
- "${FILESDIR}"/${PN}-disable-ccache-autodetection.patch
- "${FILESDIR}"/${PN}-1.15.4-backport-ce83fec.patch
-)
-
-pkg_setup() {
- python-any-r1_pkg_setup
-}
-
-src_configure() {
- # bug https://bugs.gentoo.org/926079
- filter-lto
-
- local -a mycmakeargs=(
- -DBUILD_SHARED_LIBS=OFF
- -DCMAKE_SKIP_RPATH=ON
- -DHEADLESS=false
- -DUSE_SYSTEM_FFMPEG=ON
- -DUSE_SYSTEM_LIBZIP=ON
- -DUSE_SYSTEM_SNAPPY=ON
- -DUSE_SYSTEM_ZSTD=ON
- -DUSE_DISCORD=$(usex discord)
- -DUSING_QT_UI=$(usex qt5)
- -DUNITTEST=$(usex test)
- )
- cmake_src_configure
-}
-
-src_test() {
- cmake_src_test -E glslang-testsuite
-}