summaryrefslogtreecommitdiff
path: root/games-emulation/pcsx2/pcsx2-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/pcsx2/pcsx2-9999.ebuild')
-rw-r--r--games-emulation/pcsx2/pcsx2-9999.ebuild16
1 files changed, 13 insertions, 3 deletions
diff --git a/games-emulation/pcsx2/pcsx2-9999.ebuild b/games-emulation/pcsx2/pcsx2-9999.ebuild
index 2608f0e1b287..ca3efae59de9 100644
--- a/games-emulation/pcsx2/pcsx2-9999.ebuild
+++ b/games-emulation/pcsx2/pcsx2-9999.ebuild
@@ -10,6 +10,7 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/PCSX2/pcsx2.git"
else
HASH_FASTFLOAT=32d21dcecb404514f94fb58660b8029a4673c2c1
+ HASH_FMT=b6f4ceaed0a0a24ccf575fab6c56dd50ccf6f1a9
HASH_RCHEEVOS=31f8788fe0e694e99db7ce138d45a655c556fa96
HASH_GLSLANG=c9706bdda0ac22b9856f1aa8261e5b9e15cd20c5
HASH_VULKAN=9f4c61a31435a7a90a314fc68aeb386c92a09c0f
@@ -17,6 +18,8 @@ else
https://github.com/PCSX2/pcsx2/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
https://github.com/fastfloat/fast_float/archive/${HASH_FASTFLOAT}.tar.gz
-> ${PN}-fast_float-${HASH_FASTFLOAT::10}.tar.gz
+ https://github.com/fmtlib/fmt/archive/${HASH_FMT}.tar.gz
+ -> ${PN}-fmt-${HASH_FMT::10}.tar.gz
https://github.com/RetroAchievements/rcheevos/archive/${HASH_RCHEEVOS}.tar.gz
-> ${PN}-rcheevos-${HASH_RCHEEVOS::10}.tar.gz
vulkan? (
@@ -46,7 +49,6 @@ RDEPEND="
dev-cpp/rapidyaml:=
dev-libs/libaio
dev-libs/libchdr
- dev-libs/libfmt:=
dev-libs/libzip:=[zstd]
dev-qt/qtbase:6[gui,network,widgets]
dev-qt/qtsvg:6
@@ -87,6 +89,10 @@ PATCHES=(
src_unpack() {
if [[ ${PV} == 9999 ]]; then
local EGIT_SUBMODULES=(
+ # libfmt is volatile and upstream is unlikely to make fixes for
+ # latest system copy punctually (may revisit this eventually)
+ 3rdparty/fmt/fmt
+
# has no build system and is not really setup for unbundling
3rdparty/rcheevos/rcheevos
@@ -112,6 +118,9 @@ src_unpack() {
mv fast_float-${HASH_FASTFLOAT} \
"${S}"/3rdparty/rapidyaml/rapidyaml/ext/c4core/src/c4/ext/fast_float || die
+ rmdir "${S}"/3rdparty/fmt/fmt || die
+ mv fmt-${HASH_FMT} "${S}"/3rdparty/fmt/fmt || die
+
rmdir "${S}"/3rdparty/rcheevos/rcheevos || die
mv rcheevos-${HASH_RCHEEVOS} "${S}"/3rdparty/rcheevos/rcheevos || die
@@ -137,8 +146,8 @@ src_prepare() {
local keep=(
# TODO?: rapidjson and xbyak are packaged and could be unbundlable
# w/ patch, and discord-rpc be optional w/ dependency on rapidjson
- cpuinfo cubeb demangler discord-rpc glad imgui include jpgd lzma
- rapidjson rapidyaml rcheevos simpleini xbyak zydis
+ cpuinfo cubeb demangler discord-rpc fmt glad imgui include jpgd
+ lzma rapidjson rapidyaml rcheevos simpleini xbyak zydis
$(usev vulkan 'glslang vulkan-headers')
)
find 3rdparty -mindepth 1 -maxdepth 1 -type d \
@@ -165,6 +174,7 @@ src_configure() {
# libs, system installs, or any modifications and may disregard any
# bugs that is not reproducible with the appimage using bundled libs
-DUSE_SYSTEM_LIBS=yes
+ -DUSE_SYSTEM_FMT=no # volatile, keep bundled at least "for now"
# sse4.1 is the bare minimum required, -m is required at build time
# (see PCSX2Base.h) and it dies if no support at runtime (AppInit.cpp)