summaryrefslogtreecommitdiff
path: root/games-emulation/pcsx2/pcsx2-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/pcsx2/pcsx2-9999.ebuild')
-rw-r--r--games-emulation/pcsx2/pcsx2-9999.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/games-emulation/pcsx2/pcsx2-9999.ebuild b/games-emulation/pcsx2/pcsx2-9999.ebuild
index 0f0a49453d1f..3de99b803123 100644
--- a/games-emulation/pcsx2/pcsx2-9999.ebuild
+++ b/games-emulation/pcsx2/pcsx2-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake git-r3 multilib toolchain-funcs wxwidgets
+inherit cmake flag-o-matic git-r3 multilib toolchain-funcs wxwidgets
DESCRIPTION="A PlayStation 2 emulator"
HOMEPAGE="https://www.pcsx2.net"
@@ -34,7 +34,6 @@ RDEPEND="
x11-libs/libXext[abi_x86_32(-)]
>=x11-libs/wxGTK-3.0.4-r301:3.0-gtk3[abi_x86_32(-),X]
"
-# Ensure no incompatible headers from eselect-opengl are installed, bug #510730
DEPEND="${RDEPEND}
dev-cpp/pngpp
dev-cpp/sparsehash
@@ -52,6 +51,9 @@ pkg_setup() {
src_configure() {
multilib_toolchain_setup x86
+ # Build with ld.gold fails
+ # https://github.com/PCSX2/pcsx2/issues/1671
+ tc-ld-disable-gold
# pcsx2 build scripts will force CMAKE_BUILD_TYPE=Devel
# if it something other than "Devel|Debug|Release"