summaryrefslogtreecommitdiff
path: root/games-emulation/pcsx2/pcsx2-1.7.5724.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/pcsx2/pcsx2-1.7.5724.ebuild')
-rw-r--r--games-emulation/pcsx2/pcsx2-1.7.5724.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/games-emulation/pcsx2/pcsx2-1.7.5724.ebuild b/games-emulation/pcsx2/pcsx2-1.7.5724.ebuild
index 5c49263139b5..634e5d0a4e32 100644
--- a/games-emulation/pcsx2/pcsx2-1.7.5724.ebuild
+++ b/games-emulation/pcsx2/pcsx2-1.7.5724.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake desktop fcaps flag-o-matic toolchain-funcs
+inherit cmake desktop fcaps flag-o-matic optfeature toolchain-funcs
if [[ ${PV} == 9999 ]]; then
inherit git-r3
@@ -152,6 +152,10 @@ src_install() {
pkg_postinst() {
fcaps -m 0755 cap_net_admin,cap_net_raw=eip usr/lib/${PN}/pcsx2-qt
+ # calls aplay (or gst-play/launch-1.0 as fallback in next version)
+ # https://github.com/PCSX2/pcsx2/issues/11141
+ optfeature "UI sound effects support" media-sound/alsa-utils
+
if [[ ${REPLACING_VERSIONS##* } ]] &&
ver_test ${REPLACING_VERSIONS##* } -lt 1.7; then
elog ">=${PN}-1.7 has received several changes since <=${PN}-1.6.0, and is"