summaryrefslogtreecommitdiff
path: root/games-emulation/mupen64plus-ui-console
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/mupen64plus-ui-console')
-rw-r--r--games-emulation/mupen64plus-ui-console/Manifest5
-rw-r--r--games-emulation/mupen64plus-ui-console/files/mupen64plus-ui-console-2.5.9-fix-makefile.patch32
-rw-r--r--games-emulation/mupen64plus-ui-console/mupen64plus-ui-console-2.5-r1.ebuild2
-rw-r--r--games-emulation/mupen64plus-ui-console/mupen64plus-ui-console-2.5.9.ebuild87
4 files changed, 124 insertions, 2 deletions
diff --git a/games-emulation/mupen64plus-ui-console/Manifest b/games-emulation/mupen64plus-ui-console/Manifest
index 4e31b84ce720..b343569d313b 100644
--- a/games-emulation/mupen64plus-ui-console/Manifest
+++ b/games-emulation/mupen64plus-ui-console/Manifest
@@ -1,3 +1,6 @@
+AUX mupen64plus-ui-console-2.5.9-fix-makefile.patch 986 BLAKE2B d8aa49eab82131df2a05ad5f446c9ba78c5e3102fcb9ef85a7cfd357331e59018afe65628d8f56b501016823496352871b955a2b96350d023c6a5471434de72f SHA512 6361c8edf1ec2dce5d28eefb7890deb7ebf42fc214b16349b83104215c6374cb5d8513998942539ac8c15f35833f51fc8004b815be267aedefe14fb204c32251
+DIST mupen64plus-ui-console-src-2.5.9.tar.gz 58934 BLAKE2B 83fb9502ba910af75eff62a45ac490a7281db27cf7df4c666382eb922249e1483cbfcc204e79e3763d047c876558531021360078e81abb7995c855b274e182b9 SHA512 60be63e94c8a2e44a8f4f215f667bc980f62bee3ba629af53d281328f45e016dbadfc6b7596ac657fd434b9df283d43b54a058cba2cdce3fef4b865adbedd8ca
DIST mupen64plus-ui-console-src-2.5.tar.gz 47852 BLAKE2B 060d93c82b63c5870feffd665513d3a9046c3583103ccd16014865b621f33e2eafc93af5813332ab9416c4b01b6f767ed8b4ff4d08939abee60193638ce9cdb5 SHA512 70293a768c2bc5f80a2f71db229021d497d675536f5dc5eb098f91b62081f993f308d410adebce208a89880f57b037d5b42fa2f95c42ce94ffe2fca326a53046
-EBUILD mupen64plus-ui-console-2.5-r1.ebuild 1972 BLAKE2B fbac239e530710cc18c847be2464b13ff491b00cfb585276058f9a5b81b2817ee3e2603f5aa1ed8cdbd4e4da9cc30c7aed50732b4b463a26fce35c5f3bed8e20 SHA512 bdcc0d134c8bc1651443e671ffe99ad2de7ad2ad6a32643b560fd260522602045e386ead435bc3d927f3864129a7efb7a5f83e404bc29e88c0cf9b484d9b092a
+EBUILD mupen64plus-ui-console-2.5-r1.ebuild 1973 BLAKE2B d09e5eb9a9913d0f24cc1e15fbdc9e802419c976387509c35ac3b08da2f64759b8bbbb36a92b2226c2265c18f79f15804c1f463fb04a9410c18abb3d47d5a5f2 SHA512 9e959010ded37e60df3b6148184ab5bc04a2dc96541705b55bc5d1ecada51dad1829f7a1116b6181d7b837a2205b1fbf355b41ab45344004d9f8e3539244d242
+EBUILD mupen64plus-ui-console-2.5.9.ebuild 1843 BLAKE2B 245bca8087b0dd668cf7ca5ce710646fe79e5e2c945d28eea36d44be378fa790bc1a15f8de4649ec740572306de4078cec2e673e8483eb04953fd7976f546c20 SHA512 29e14a442168e356b01420038346916af9a5afc2ca4826b997255d87cda34efe7a43c183eb3346107d84bb4f6fd0ec146cdee014fdc02d64b88cca03ee80c2b7
MISC metadata.xml 346 BLAKE2B 823a53023d0e1834cac987cde3eebf3164767e2793ef0805c28c90a04f040b6d34d8acb8d1f28a528f74b0c269a99bfe8b7d648c5c38c6a89df59846096b79fe SHA512 2e43f2c7bd5fdfffbf8c9ece665093b942d1e3c76b27f851fff7de030ecfc0f38e82e730740e1688413b47e0ba1b752f96ebcd1d1c2a6107bcbd8185630db4c8
diff --git a/games-emulation/mupen64plus-ui-console/files/mupen64plus-ui-console-2.5.9-fix-makefile.patch b/games-emulation/mupen64plus-ui-console/files/mupen64plus-ui-console-2.5.9-fix-makefile.patch
new file mode 100644
index 000000000000..c14491e70496
--- /dev/null
+++ b/games-emulation/mupen64plus-ui-console/files/mupen64plus-ui-console-2.5.9-fix-makefile.patch
@@ -0,0 +1,32 @@
+--- a/projects/unix/Makefile
++++ b/projects/unix/Makefile
+@@ -94,7 +94,7 @@
+ ifeq ($(ARCH_DETECTED), 64BITS)
+ CFLAGS += -pipe -arch x86_64 -mmacosx-version-min=10.6 -isysroot $(OSX_SDK_PATH)
+ else
+- CFLAGS += -pipe -mmmx -msse -fomit-frame-pointer -arch i686 -mmacosx-version-min=10.6 -isysroot $(OSX_SDK_PATH)
++ CFLAGS += -pipe -arch i686 -mmacosx-version-min=10.6 -isysroot $(OSX_SDK_PATH)
+ endif
+ endif
+ endif
+@@ -172,20 +172,6 @@
+ COMPILE.c = $(Q_CC)$(CC) $(CFLAGS) $(CPPFLAGS) $(TARGET_ARCH) -c
+ LINK.o = $(Q_LD)$(CC) $(CFLAGS) $(LDFLAGS) $(TARGET_ARCH)
+
+-ifeq ($(PIE), 1)
+- CFLAGS += -fPIE
+- LDFLAGS += -pie
+-else
+- CFLAGS += -fno-PIE
+- ifeq ($(CC),$(CROSS_COMPILE)gcc)
+- # check if PIE is the default for the compiler
+- PIE_DEFAULT = $(shell $(CC) -v 2>&1 | grep enable-default-pie)
+- ifneq ($(PIE_DEFAULT),)
+- LDFLAGS += -no-pie
+- endif
+- endif
+-endif
+-
+ # set installation options
+ ifeq ($(PREFIX),)
+ PREFIX := /usr/local
diff --git a/games-emulation/mupen64plus-ui-console/mupen64plus-ui-console-2.5-r1.ebuild b/games-emulation/mupen64plus-ui-console/mupen64plus-ui-console-2.5-r1.ebuild
index d937a15d77d5..61ba3cd2e326 100644
--- a/games-emulation/mupen64plus-ui-console/mupen64plus-ui-console-2.5-r1.ebuild
+++ b/games-emulation/mupen64plus-ui-console/mupen64plus-ui-console-2.5-r1.ebuild
@@ -7,7 +7,7 @@ MY_P=${PN}-src-${PV}
inherit eutils gnome2-utils multilib toolchain-funcs xdg-utils
DESCRIPTION="A fork of Mupen64 Nintendo 64 emulator, console UI"
-HOMEPAGE="http://www.mupen64plus.org/"
+HOMEPAGE="https://www.mupen64plus.org/"
SRC_URI="https://github.com/mupen64plus/${PN}/releases/download/${PV}/${MY_P}.tar.gz"
LICENSE="GPL-2 LGPL-2.1"
diff --git a/games-emulation/mupen64plus-ui-console/mupen64plus-ui-console-2.5.9.ebuild b/games-emulation/mupen64plus-ui-console/mupen64plus-ui-console-2.5.9.ebuild
new file mode 100644
index 000000000000..ec20f855224b
--- /dev/null
+++ b/games-emulation/mupen64plus-ui-console/mupen64plus-ui-console-2.5.9.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P=${PN}-src-${PV}
+inherit toolchain-funcs xdg-utils
+
+DESCRIPTION="A fork of Mupen64 Nintendo 64 emulator, console UI"
+HOMEPAGE="https://www.mupen64plus.org/"
+SRC_URI="https://github.com/mupen64plus/${PN}/releases/download/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=games-emulation/mupen64plus-core-${PV}:0=
+ media-libs/libsdl2:0=
+ !<games-emulation/mupen64plus-2.0"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+ # 1. avoid implicitly appending CPU flags
+ # 2. avoid appending -fPIE/-fno-PIE
+ "${FILESDIR}"/${PN}-2.5.9-fix-makefile.patch
+)
+
+src_compile() {
+ MAKEARGS=(
+ # Note: please keep this in sync in all of mupen64plus-* packages
+
+ -C projects/unix
+
+ # this basically means: GNU userspace
+ UNAME=Linux
+
+ # verbose output
+ V=1
+
+ CROSS_COMPILE="${CHOST}-"
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+ # usual CFLAGS, CXXFLAGS and LDFLAGS are respected
+ # so we can leave OPTFLAGS empty
+ OPTFLAGS=
+
+ # paths, some of them are used at compile time
+ PREFIX=/usr
+ LIBDIR=/usr/$(get_libdir)
+
+ # disable unwanted magic
+ LDCONFIG=:
+ INSTALL_STRIP_FLAG=
+
+ # Package-specific stuff
+
+ # CROSS_COMPILE causes it to look for ${CHOST}-sdl2-config...
+ SDL_CFLAGS="$($(tc-getPKG_CONFIG) --cflags sdl2)"
+ SDL_LDLIBS="$($(tc-getPKG_CONFIG) --libs sdl2)"
+ )
+
+ use amd64 && MAKEARGS+=( HOST_CPU=x86_64 )
+ use x86 && MAKEARGS+=( HOST_CPU=i386 )
+
+ emake "${MAKEARGS[@]}" all
+}
+
+src_install() {
+ emake "${MAKEARGS[@]}" DESTDIR="${D}" install
+ dodoc README RELEASE
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}