summaryrefslogtreecommitdiff
path: root/games-emulation/mupen64plus-rsp-hle
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/mupen64plus-rsp-hle')
-rw-r--r--games-emulation/mupen64plus-rsp-hle/Manifest4
-rw-r--r--games-emulation/mupen64plus-rsp-hle/mupen64plus-rsp-hle-2.5.9.ebuild68
-rw-r--r--games-emulation/mupen64plus-rsp-hle/mupen64plus-rsp-hle-2.5.ebuild2
3 files changed, 72 insertions, 2 deletions
diff --git a/games-emulation/mupen64plus-rsp-hle/Manifest b/games-emulation/mupen64plus-rsp-hle/Manifest
index e5c156f654bb..c5cbba95a7a2 100644
--- a/games-emulation/mupen64plus-rsp-hle/Manifest
+++ b/games-emulation/mupen64plus-rsp-hle/Manifest
@@ -1,3 +1,5 @@
+DIST mupen64plus-rsp-hle-src-2.5.9.tar.gz 53889 BLAKE2B e66996ffbce1d4b2b40f1520f0806692652dbf7baa55a73f632f2dafe75f93093e0575bb1c7e63cc1cd8770c1cc0e6d59db9021fcb0fa2e34d707511dd3a40b0 SHA512 562f3a9d9eff01f11c13aca657fb6471f365fbfbe079ea5e1e6f0ad49b27ba04779bc86233bcacd20c95c79f7fa265f053b3fa4c2b12828c6a8992762c4b6963
DIST mupen64plus-rsp-hle-src-2.5.tar.gz 46998 BLAKE2B 3bb5ee627fa4c367e7dd1ef0ac0a1eae1267cf82ac66a35f4dcd972703b9cba832224cab1be20c75e9f61af2afae0c8eb7dd6ba806a47c57eef6e6c5da9e8a5a SHA512 564d96050890cc61df05163f99a0be8198e870f0d4071e87828bf58b283b2be8ca7de20ed03482ea8c45725bdd6f6baea618c068cced407892cf2add6ef373c6
-EBUILD mupen64plus-rsp-hle-2.5.ebuild 1435 BLAKE2B 5568b185559e3c6a5785f696fe81c612df394fef03322a365aca1d0f8d566ba8192d84fd7884cf423fefc66d45a026ead20ef834e6bff730f339e7f033c9672e SHA512 27e3c65ff9d57bf70dc9894f3e90962971d069aecc06f7c9db2dadae82af36f1fb0d2bbe10c70a8f8ce01378382ca8216ca05c7d9aab4ec9ded7ce919021eaba
+EBUILD mupen64plus-rsp-hle-2.5.9.ebuild 1405 BLAKE2B 82845f868656311d6a36539835db4c7730378b68e342d4d25ea6616bb0e5728a27cfefd69151e43d4472b01531695d5331904c3d98dbc403291f7da5e742d116 SHA512 7d5554bd4e866724b48ba928125b00929aa14d4ad3269d081a8320657894a6f6b424ec8b76c6e5cebdf64b2c17d7ad9bc62f9a533badd122bf817140057c49bc
+EBUILD mupen64plus-rsp-hle-2.5.ebuild 1436 BLAKE2B 2117c79ab4e074ac9102a2f8ba7f7aec2650a3d44ff954751e45fb3f31d624a8227443e07bab024c8cf4a3d4f6c80da781be30c832167812aba6280bffc72f3d SHA512 d40d0c73f4f779030b02f2c03d91b54f6b9367e2d36050715d4363b344d7c4837e07f96d72a624ef49877346ef24257cf074d7f065a9cae4759a85e49f30334e
MISC metadata.xml 343 BLAKE2B 997f47a4d8c1fccab5b16dd49ab4e791ec1ae114b820ad75839f981e9a72f409951a22abfbb68788ade5dcb1be2dd91aba4fc9771c00519307ee28455ab7aa9d SHA512 7ffba7fdacc44215dba6cf994646ea38ebf94870accc3d6150ca609fcf5dc7b343a52fe6fc0511e5741f24afc20b11c2e1104d39215f7cffdeaf1098efaf709e
diff --git a/games-emulation/mupen64plus-rsp-hle/mupen64plus-rsp-hle-2.5.9.ebuild b/games-emulation/mupen64plus-rsp-hle/mupen64plus-rsp-hle-2.5.9.ebuild
new file mode 100644
index 000000000000..4d18794f870b
--- /dev/null
+++ b/games-emulation/mupen64plus-rsp-hle/mupen64plus-rsp-hle-2.5.9.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P=${PN}-src-${PV}
+inherit toolchain-funcs
+
+DESCRIPTION="A fork of Mupen64 Nintendo 64 emulator, HLE RSP plugin"
+HOMEPAGE="https://www.mupen64plus.org/"
+SRC_URI="https://github.com/mupen64plus/${PN}/releases/download/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=games-emulation/mupen64plus-core-${PV}:0="
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ default
+
+ # avoid implicitly appending CPU flags
+ sed -i -e 's:-mmmx::g' -e 's:-msse::g' projects/unix/Makefile || die
+}
+
+src_compile() {
+ MAKEARGS=(
+ # Note: please keep this in sync in all of mupen64plus-* packages
+
+ -C projects/unix
+
+ # this basically means: GNU userspace
+ UNAME=Linux
+
+ # verbose output
+ V=1
+
+ CROSS_COMPILE="${CHOST}-"
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+ # usual CFLAGS, CXXFLAGS and LDFLAGS are respected
+ # so we can leave OPTFLAGS empty
+ OPTFLAGS=
+
+ # paths, some of them are used at compile time
+ PREFIX=/usr
+ LIBDIR=/usr/$(get_libdir)
+
+ # disable unwanted magic
+ LDCONFIG=:
+ INSTALL_STRIP_FLAG=
+ )
+
+ use amd64 && MAKEARGS+=( HOST_CPU=x86_64 )
+ use x86 && MAKEARGS+=( HOST_CPU=i386 )
+
+ emake "${MAKEARGS[@]}" all
+}
+
+src_install() {
+ emake "${MAKEARGS[@]}" DESTDIR="${D}" install
+ dodoc RELEASE
+}
diff --git a/games-emulation/mupen64plus-rsp-hle/mupen64plus-rsp-hle-2.5.ebuild b/games-emulation/mupen64plus-rsp-hle/mupen64plus-rsp-hle-2.5.ebuild
index b326e6251588..8f6c7676bce9 100644
--- a/games-emulation/mupen64plus-rsp-hle/mupen64plus-rsp-hle-2.5.ebuild
+++ b/games-emulation/mupen64plus-rsp-hle/mupen64plus-rsp-hle-2.5.ebuild
@@ -7,7 +7,7 @@ MY_P=${PN}-src-${PV}
inherit eutils multilib toolchain-funcs
DESCRIPTION="A fork of Mupen64 Nintendo 64 emulator, HLE RSP plugin"
-HOMEPAGE="http://www.mupen64plus.org/"
+HOMEPAGE="https://www.mupen64plus.org/"
SRC_URI="https://github.com/mupen64plus/${PN}/releases/download/${PV}/${MY_P}.tar.gz"
LICENSE="GPL-2 LGPL-2.1"