summaryrefslogtreecommitdiff
path: root/games-emulation/melonds/melonds-0.9.5-r5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/melonds/melonds-0.9.5-r5.ebuild')
-rw-r--r--games-emulation/melonds/melonds-0.9.5-r5.ebuild96
1 files changed, 0 insertions, 96 deletions
diff --git a/games-emulation/melonds/melonds-0.9.5-r5.ebuild b/games-emulation/melonds/melonds-0.9.5-r5.ebuild
deleted file mode 100644
index ae2f49cc74cb..000000000000
--- a/games-emulation/melonds/melonds-0.9.5-r5.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 2019-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-MY_PN="melonDS"
-MY_P="${MY_PN}-${PV}"
-
-inherit cmake flag-o-matic readme.gentoo-r1 toolchain-funcs xdg
-
-DESCRIPTION="Nintendo DS emulator, sorta"
-HOMEPAGE="http://melonds.kuribo64.net
- https://github.com/Arisotura/melonDS"
-
-if [[ "${PV}" == *9999* ]] ; then
- inherit git-r3
-
- EGIT_REPO_URI="https://github.com/Arisotura/${MY_PN}.git"
-else
- SRC_URI="https://github.com/Arisotura/${MY_PN}/archive/${PV}.tar.gz
- -> ${MY_P}.tar.gz"
- S="${WORKDIR}/${MY_P}"
-
- KEYWORDS="amd64"
-fi
-
-IUSE="+jit +opengl"
-LICENSE="BSD-2 GPL-2 GPL-3 Unlicense"
-SLOT="0"
-
-RDEPEND="
- app-arch/libarchive
- dev-libs/wayland
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtmultimedia:5
- dev-qt/qtnetwork:5
- dev-qt/qtwidgets:5
- media-libs/libsdl2[sound,video]
- net-libs/libpcap
- net-libs/libslirp
-"
-DEPEND="
- ${RDEPEND}
-"
-BDEPEND="
- kde-frameworks/extra-cmake-modules:0
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.9.5-DSi_Camera-algorithm.patch"
- "${FILESDIR}/${PN}-0.9.5-no-ccache-detection.patch"
-)
-
-# used for JIT recompiler
-QA_EXECSTACK="usr/bin/melonDS"
-
-DISABLE_AUTOFORMATTING="yes"
-DOC_CONTENTS="You need the following files in order to run melonDS:
-- bios7.bin
-- bios9.bin
-- firmware.bin
-- romlist.bin
-Place them in ~/.config/melonDS
-Those files can be extracted from devices or found somewhere on the Internet ;-)"
-
-src_prepare() {
- filter-lto
- append-flags -fno-strict-aliasing
-
- cmake_src_prepare
-}
-
-src_configure() {
- local -a mycmakeargs=(
- -DBUILD_SHARED_LIBS=OFF
- -DENABLE_JIT=$(usex jit)
- -DENABLE_OGLRENDERER=$(usex opengl)
- )
- cmake_src_configure
-}
-
-src_compile() {
- tc-export AR
- cmake_src_compile
-}
-
-src_install() {
- readme.gentoo_create_doc
- cmake_src_install
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
- readme.gentoo_print_elog
-}