summaryrefslogtreecommitdiff
path: root/games-emulation/mednaffe/mednaffe-0.9.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/mednaffe/mednaffe-0.9.3.ebuild')
-rw-r--r--games-emulation/mednaffe/mednaffe-0.9.3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/games-emulation/mednaffe/mednaffe-0.9.3.ebuild b/games-emulation/mednaffe/mednaffe-0.9.3.ebuild
new file mode 100644
index 000000000000..fa5be892ce40
--- /dev/null
+++ b/games-emulation/mednaffe/mednaffe-0.9.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg
+
+DESCRIPTION="Front-end (GUI) for mednafen emulator"
+HOMEPAGE="https://github.com/AmatCoder/mednaffe/"
+SRC_URI="https://github.com/AmatCoder/mednaffe/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+"
+RDEPEND="
+ ${DEPEND}
+ games-emulation/mednafen
+"
+BDEPEND="
+ virtual/pkgconfig
+"