summaryrefslogtreecommitdiff
path: root/games-emulation/gngeo/files
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/gngeo/files')
-rw-r--r--games-emulation/gngeo/files/gngeo-0.8-cflags.patch41
-rw-r--r--games-emulation/gngeo/files/gngeo-0.8-concurrentMake.patch16
-rw-r--r--games-emulation/gngeo/files/gngeo-0.8-execstacks.patch105
-rw-r--r--games-emulation/gngeo/files/gngeo-0.8-zlib.patch9
4 files changed, 0 insertions, 171 deletions
diff --git a/games-emulation/gngeo/files/gngeo-0.8-cflags.patch b/games-emulation/gngeo/files/gngeo-0.8-cflags.patch
deleted file mode 100644
index 0dcc3e7c5bf8..000000000000
--- a/games-emulation/gngeo/files/gngeo-0.8-cflags.patch
+++ /dev/null
@@ -1,41 +0,0 @@
---- a/configure.in.orig 2016-03-31 04:15:45.913917791 -0400
-+++ b/configure.in 2016-03-31 04:16:23.447607551 -0400
-@@ -236,20 +236,12 @@
- AC_DEFINE(PROCESSOR_INTEL, 1, [Define if you have an x86 processor])
- ALIGNLONGS=0
- proc_i386=true
-- CFLAGS="$CFLAGS -O3 -fstrength-reduce -frerun-loop-opt -Wall -Wno-unused -funroll-loops \
-- -ffast-math -falign-functions=2 -falign-jumps=2 -fexpensive-optimizations \
-- -falign-loops=2 -fschedule-insns2 -malign-double -fomit-frame-pointer -g \
-- -fno-strict-aliasing -pipe -mtune=$target_cpu -DCPU=$target_cpu"
- ;;
- x86_64)
- AC_MSG_RESULT(Turning on x86_64 processor optimisations)
- AC_DEFINE(PROCESSOR_ADM64, 1, [Define if you have an x86_64 processor])
- ALIGNLONGS=0
- proc_x64=true
-- CFLAGS="$CFLAGS -O3 -fstrength-reduce -frerun-loop-opt -Wall -Wno-unused -funroll-loops \
-- -ffast-math -fexpensive-optimizations \
-- -malign-double -fomit-frame-pointer -g \
-- -fno-strict-aliasing -pipe -DCPU=$target_cpu"
- ;;
- sparc*) AC_MSG_RESULT(Turning on sparc processor optimisations)
- AC_DEFINE(PROCESSOR_SPARC, 1, [Define if you have a sparc processor])
-@@ -258,8 +250,6 @@
- if test $target_cpu = sparc64 && test $CC_MAJOR -ge 3 ; then
- CFLAGS="$CFLAGS -mcpu=v9"
- fi
-- CFLAGS="$CFLAGS -O3 -Wall -Wno-unused -funroll-loops \
-- -ffast-math -fomit-frame-pointer -g"
- ;;
- arm) AC_MSG_RESULT(Turning on arm processor optimisations)
- AC_DEFINE(PROCESSOR_ARM, 1, [Define if you have an ARM processor])
-@@ -273,8 +263,6 @@
- *) AC_MSG_RESULT(Processor type unknown - Use generic optimisations)
- ALIGNLONGS=1
- optimum=no
-- CFLAGS="$CFLAGS -O3 -Wall -Wno-unused -funroll-loops \
-- -ffast-math -g"
- ;;
- esac
-
diff --git a/games-emulation/gngeo/files/gngeo-0.8-concurrentMake.patch b/games-emulation/gngeo/files/gngeo-0.8-concurrentMake.patch
deleted file mode 100644
index f039ecf544d9..000000000000
--- a/games-emulation/gngeo/files/gngeo-0.8-concurrentMake.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- a/src/generator68k/Makefile.am.orig 2015-01-23 18:37:37.998723294 -0500
-+++ b/src/generator68k/Makefile.am 2015-01-23 18:38:39.995391133 -0500
-@@ -71,9 +71,12 @@
-
- #def68k : def68k.c
- # gcc def68k.c tab68k.c -o def68k -I .. -I ../.. -I . `sdl-config --cflags`
--def68k.o gen68k.o tab68k2.o : %.o : %.c
-+def68k.o tab68k2.o : %.o : %.c
- $(gcc_build_verbose)$(CC_FOR_BUILD) -c $< -o $@ -I .. -I ../.. -I . `sdl-config --cflags`
-
-+gen68k.o: gen68k.c def68k-iibs.h
-+ $(CC_FOR_BUILD) -c $< -o $@ -I .. -I ../.. -I . `sdl-config --cflags`
-+
- def68k : def68k.o tab68k2.o
- $(gcc_build_verbose)$(CC_FOR_BUILD) def68k.o tab68k2.o -o $@
-
diff --git a/games-emulation/gngeo/files/gngeo-0.8-execstacks.patch b/games-emulation/gngeo/files/gngeo-0.8-execstacks.patch
deleted file mode 100644
index a3face06f35c..000000000000
--- a/games-emulation/gngeo/files/gngeo-0.8-execstacks.patch
+++ /dev/null
@@ -1,105 +0,0 @@
---- a/src/effect/2xsaimmx.asm
-+++ b/src/effect/2xsaimmx.asm
-@@ -2107,3 +2107,7 @@
- final1b resb 8
- final2a resb 8
- final2b resb 8
-+
-+%ifidn __OUTPUT_FORMAT__,elf
-+section .note.GNU-stack noalloc noexec nowrite progbits
-+%endif
---- a/src/effect/effect_i386.asm
-+++ b/src/effect/effect_i386.asm
-@@ -88,3 +88,7 @@
- emms
-
- endproc
-+
-+%ifidn __OUTPUT_FORMAT__,elf
-+section .note.GNU-stack noalloc noexec nowrite progbits
-+%endif
---- a/src/effect/hq2x16.asm
-+++ b/src/effect/hq2x16.asm
-@@ -1935,3 +1935,7 @@
- dd ..@cross8, ..@flag0, ..@flag0, ..@flag0,
- dd ..@flag0, ..@flag0, ..@flag0, ..@flag0
-
-+
-+%ifidn __OUTPUT_FORMAT__,elf
-+section .note.GNU-stack noalloc noexec nowrite progbits
-+%endif
---- a/src/effect/hq3x16.asm
-+++ b/src/effect/hq3x16.asm
-@@ -2520,3 +2520,7 @@
- dd ..@cross8, ..@flag0, ..@flag0, ..@flag0,
- dd ..@flag0, ..@flag0, ..@flag0, ..@flag0
-
-+
-+%ifidn __OUTPUT_FORMAT__,elf
-+section .note.GNU-stack noalloc noexec nowrite progbits
-+%endif
---- a/src/memcpy.S
-+++ b/src/memcpy.S
-@@ -495,4 +495,8 @@
-
- Lmemcpy_bsrcul1l4:
- add r1, r1, #1
--b Lmemcpy_bl4
-\ No newline at end of file
-+b Lmemcpy_bl4
-+
-+#ifdef __ELF__
-+.section .note.GNU-stack,"",@progbits
-+#endif
---- a/src/raze/Makefile.am
-+++ b/src/raze/Makefile.am
-@@ -20,7 +20,7 @@
- $(srcdir)/strip_ $< $@
-
- raze2.asm: raze.asmu raze.incu raze.regu
-- nasm -w+orphan-labels -I $(srcdir)/ -e $< -o $@
-+ nasm -w+orphan-labels -f elf -I $(srcdir)/ -e $< -o $@
-
- # This assembles the file, once it's been pre-processed
- raze.o: raze2.asm
---- a/src/raze/raze.asm
-+++ b/src/raze/raze.asm
-@@ -4259,3 +4259,6 @@
-
- ;- the end ------------------------------------------------------------------;
-
-+%ifidn ___OUTPUT_FORMAT__,elf
-+section .note.GNU-stack noalloc noexec nowrite progbits
-+%endif
---- a/src/screen_i386.asm
-+++ b/src/screen_i386.asm
-@@ -96,3 +96,6 @@
- endproc
-
-
-+%ifidn __OUTPUT_FORMAT__,elf
-+section .note.GNU-stack noalloc noexec nowrite progbits
-+%endif
---- a/src/star/star.c
-+++ b/src/star/star.c
-@@ -2431,6 +2431,10 @@
- */
- static void suffixes(void) {
- emit("end\n");
-+
-+ emit("%%ifidn ___OUTPUT_FORMAT__,elf\n");
-+ emit("section .note.GNU-stack noalloc noexec nowrite progbits\n");
-+ emit("%%endif\n");
- }
-
- /****************************************************************************
---- a/src/video_i386.asm
-+++ b/src/video_i386.asm
-@@ -86,3 +86,7 @@
-
- popa
- endproc
-+
-+%ifidn __OUTPUT_FORMAT__,elf
-+section .note.GNU-stack noalloc noexec nowrite progbits
-+%endif
diff --git a/games-emulation/gngeo/files/gngeo-0.8-zlib.patch b/games-emulation/gngeo/files/gngeo-0.8-zlib.patch
deleted file mode 100644
index 9aa4a6b5f479..000000000000
--- a/games-emulation/gngeo/files/gngeo-0.8-zlib.patch
+++ /dev/null
@@ -1,9 +0,0 @@
-diff -ru gngeo-0.8.orig/configure.in gngeo-0.8/configure.in
---- gngeo-0.8.orig/configure.in 2012-11-15 17:57:57.849578009 -0500
-+++ gngeo-0.8/configure.in 2012-11-15 18:19:55.305923094 -0500
-@@ -95,6 +95,7 @@
- #AC_SUBST(LIBOBJS)
- AC_CHECK_LIB([m], [acos])
- AC_CHECK_LIB([z], [inflate])
-+AC_CHECK_LIB([minizip], [unzReadCurrentFile])
-