summaryrefslogtreecommitdiff
path: root/games-emulation/generator/generator-0.35_p4-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/generator/generator-0.35_p4-r1.ebuild')
-rw-r--r--games-emulation/generator/generator-0.35_p4-r1.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/games-emulation/generator/generator-0.35_p4-r1.ebuild b/games-emulation/generator/generator-0.35_p4-r1.ebuild
deleted file mode 100644
index 14ef210d58a8..000000000000
--- a/games-emulation/generator/generator-0.35_p4-r1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit autotools toolchain-funcs
-
-MY_P="${PN}-${PV/_p/-cbiere-r}"
-DESCRIPTION="Sega Genesis / Mega Drive emulator"
-HOMEPAGE="http://www.squish.net/generator/"
-SRC_URI="http://www.squish.net/generator/cbiere/generator/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+sdlaudio"
-
-RDEPEND="
- virtual/jpeg:0
- media-libs/libsdl[joystick,video]
- sdlaudio? ( media-libs/libsdl[sound] )
-"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- default
- eapply \
- "${FILESDIR}"/${P}-configure.patch \
- "${FILESDIR}"/${P}-underlink.patch \
- "${FILESDIR}"/${P}-inline.patch
-
- sed -i -e 's/@GTK_CFLAGS@//g' main/Makefile.am || die
- eautoreconf
-}
-
-src_configure() {
- econf \
- --with-cmz80 \
- --with-sdl \
- --without-tcltk \
- --with-gcc=$(gcc-major-version) \
- $(use_with sdlaudio sdl-audio)
-}
-
-src_compile() {
- [[ -f Makefile ]] && emake clean
- emake -j1
-}
-
-src_install() {
- dobin main/generator-sdl
- dodoc AUTHORS ChangeLog NEWS README TODO docs/*
-}