summaryrefslogtreecommitdiff
path: root/games-emulation/generator/files/generator-0.35_p4-automake.patch
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/generator/files/generator-0.35_p4-automake.patch')
-rw-r--r--games-emulation/generator/files/generator-0.35_p4-automake.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/games-emulation/generator/files/generator-0.35_p4-automake.patch b/games-emulation/generator/files/generator-0.35_p4-automake.patch
new file mode 100644
index 000000000000..e04ed94b9be8
--- /dev/null
+++ b/games-emulation/generator/files/generator-0.35_p4-automake.patch
@@ -0,0 +1,26 @@
+--- a/cpu68k/Makefile.am
++++ b/cpu68k/Makefile.am
+@@ -29,6 +29,7 @@
+
+ gen68k_SOURCES = gen68k.c tab68k.c
+ gen68k_DEPENDENCIES = def68k-iibs.h
++BUILT_SOURCES = def68k-iibs.h
+
+ noinst_LIBRARIES = lib68k.a
+ lib68k_a_SOURCES = cpu68k-0.c cpu68k-1.c cpu68k-2.c cpu68k-3.c \
+--- a/main/Makefile.am
++++ b/main/Makefile.am
+@@ -3,11 +3,11 @@
+ INCLUDES = -I../hdr -I. -I../cpu68k -I../ym2612 -I../raze -I../cmz80 \
+ -I../sn76496 -I../gtkopts \
+ -DFNAME_TCLSCRIPT=\"${datadir}/generator/gen.tcl\" \
+- @GTK_CFLAGS@ @SDL_CFLAGS@
++ @SDL_CFLAGS@
+ bin_PROGRAMS = @PROGRAM@
+ EXTRA_PROGRAMS = generator-svgalib generator-tcltk generator-allegro \
+ generator-gtk generator-sdl
+-LDADD = ../cpu68k/lib68k.a ../ym2612/libym2612.a @MY_LIBS@ \
++LDADD = ../cpu68k/lib68k.a ../ym2612/libym2612.a @MY_LIBS@ -lm \
+ ../sn76496/libsn76496.a
+
+ ## this should be generator_tcltk_DATA but it won't let me do that