summaryrefslogtreecommitdiff
path: root/games-emulation/dosbox-staging/dosbox-staging-0.75.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/dosbox-staging/dosbox-staging-0.75.1.ebuild')
-rw-r--r--games-emulation/dosbox-staging/dosbox-staging-0.75.1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/games-emulation/dosbox-staging/dosbox-staging-0.75.1.ebuild b/games-emulation/dosbox-staging/dosbox-staging-0.75.1.ebuild
new file mode 100644
index 000000000000..3ace52dd1429
--- /dev/null
+++ b/games-emulation/dosbox-staging/dosbox-staging-0.75.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools desktop
+
+DESCRIPTION="Modernized DOSBox soft-fork"
+HOMEPAGE="https://dosbox-staging.github.io/"
+SRC_URI="https://github.com/dosbox-staging/dosbox-staging/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa debug dynrec opengl opus"
+
+RDEPEND="alsa? ( media-libs/alsa-lib )
+ debug? ( sys-libs/ncurses:0= )
+ opengl? ( virtual/opengl )
+ opus? ( media-libs/opusfile )
+ media-libs/libpng:0=
+ media-libs/libsdl2[joystick,opengl?,video,X]
+ media-libs/sdl-net
+ sys-libs/zlib
+ !games-emulation/dosbox"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+PATCHES=( "${FILESDIR}"/${P}-pthread.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable alsa alsa-midi) \
+ $(use_enable debug) \
+ $(use_enable !dynrec dynamic-x86) \
+ $(use_enable dynrec) \
+ $(use_enable opengl) \
+ $(use_enable opus opus-cdda)
+}
+
+src_install() {
+ default
+ doicon contrib/icons/${PN}.svg
+ make_desktop_entry dosbox DOSBox-staging ${PN}
+}