summaryrefslogtreecommitdiff
path: root/games-emulation/dolphin
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/dolphin')
-rw-r--r--games-emulation/dolphin/Manifest2
-rw-r--r--games-emulation/dolphin/dolphin-9999.ebuild10
2 files changed, 7 insertions, 5 deletions
diff --git a/games-emulation/dolphin/Manifest b/games-emulation/dolphin/Manifest
index f4c16b86182c..e6c2809d5e88 100644
--- a/games-emulation/dolphin/Manifest
+++ b/games-emulation/dolphin/Manifest
@@ -3,5 +3,5 @@ AUX dolphin-5.0-no-pie.patch 1068 BLAKE2B e941c7002b7adaaefc5c9ea2433a1362c1698b
AUX dolphin-5.0-xgetbv.patch 1137 BLAKE2B d736d25127fae4c552c1e28b0c152037a2c0a16c59dbec873596e1488f9a9872672684f23517c6ceeef0c8b50e0f1914882a1ccd123660e4458fc9e73d1e07bd SHA512 d627829270acc69ed3dc420c57762c6a68713482c29fd0b33a38864558380c5d9547ace9ab054d2892108ccfe7751147e51c0d5495a57d02fa29c02ac93ef391
DIST dolphin-5.0.zip 41802909 BLAKE2B 57fb7741e86b8b5194c9ccaf99e60be0202429209ce98d08aec4ed1d6f47fb347d9149509de7ac1e4bb28435cba35e357b87cf5d29efe2867706dbb3b903c886 SHA512 36c4f371e066537331a9a8ec4a17befa278465cdebe258e1cbf1157752ba69bff9c1b8a6e8698bbb650aa257bd48b6b42ee9f61357904b09fd01738af8223d3a
EBUILD dolphin-5.0.ebuild 4610 BLAKE2B f10b2979143b167887758b6d70db658ce0fe4d9c0bdc57ccc87b16b5682ddebd23f9e14d5fb000b250767bd11487fa13e988b76fd6958cfa56a396c2e5adea4e SHA512 d45ab963c14353014fd9178b61ebecdb017e67ea8e99b252712acbd9732ddb31ae5125ffeaef6cd66276b526dc74955904141a88252682cf34ea3df184ac6746
-EBUILD dolphin-9999.ebuild 3880 BLAKE2B 0dfce92931037aefb0737eae135e6955b4ca312c9631024d1325933af942da935aae3db63b50d7e283f5be6655cc8ea8c7bd9ce4ab7bf569a1426fcb84227e12 SHA512 20c8bab6a8c79e15a72f5d8fd736b4012c2fc0916f6ac767f0663f77e7c141ae4563ea79e24e8526cf4e0083a5267043db260598fa3bacc4357f5e14de62b0ea
+EBUILD dolphin-9999.ebuild 3902 BLAKE2B 049e6db8a32deecb00f691939221d9d374c9da8fc648a6c7d82840d1cde88d0bcf7c72ee14c73012b594dcb743ae5a0b6ec3e59b0af0c79d1a9277315d084e4e SHA512 4e168449bab436973bfa8ef100d4913fb6873b6bbbc1541571a17a6e6ddf19514592b5c8e3d6825343fd94dfb738f5b1312a4d076e79a3c2eb610c26e5f89069
MISC metadata.xml 825 BLAKE2B 47bce78aa687f194ff5fb0252f3cdaf76336ab5460cdf72ddaa2913f36dd69aa916cbfc7684ae276248e14d092d8107ab67c7d8c37b71bfca15778b171d725f2 SHA512 33a3c378f2ed7fd25a155b29a03dd3b87730e9c910e7b2d35148a7f6eafbb75e96eab0a0f9608a9ae34e1aa2ccb5d6cc849d895cd28912c88193640a8ac5a6b5
diff --git a/games-emulation/dolphin/dolphin-9999.ebuild b/games-emulation/dolphin/dolphin-9999.ebuild
index 3294bace82d7..fcc451d6afda 100644
--- a/games-emulation/dolphin/dolphin-9999.ebuild
+++ b/games-emulation/dolphin/dolphin-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -22,7 +22,7 @@ HOMEPAGE="https://www.dolphin-emu.org/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="alsa bluetooth discord-presence doc egl +evdev ffmpeg libav log lto profile pulseaudio +qt5 systemd upnp"
+IUSE="alsa bluetooth discord-presence doc +evdev ffmpeg libav log lto profile pulseaudio +qt5 systemd upnp"
RDEPEND="
dev-libs/hidapi:0=
@@ -30,6 +30,7 @@ RDEPEND="
dev-libs/pugixml:0=
media-libs/libpng:0=
media-libs/libsfml
+ media-libs/mesa[egl]
net-libs/enet:1.3
net-libs/mbedtls
net-misc/curl:0=
@@ -42,7 +43,6 @@ RDEPEND="
virtual/opengl
alsa? ( media-libs/alsa-lib )
bluetooth? ( net-wireless/bluez )
- egl? ( media-libs/mesa[egl] )
evdev? (
dev-libs/libevdev
virtual/udev
@@ -77,8 +77,11 @@ src_prepare() {
Bochs_disasm
cpp-optparse
glslang
+ imgui
# FIXME: xxhash can't be found by cmake
xxhash
+ # no support for for using system library
+ minizip
# soundtouch uses shorts, not floats
soundtouch
cubeb
@@ -129,7 +132,6 @@ src_configure() {
-DFASTLOG=$(usex log)
-DOPROFILING=$(usex profile)
-DUSE_DISCORD_PRESENCE=$(usex discord-presence)
- -DUSE_EGL=$(usex egl)
-DUSE_SHARED_ENET=ON
-DUSE_UPNP=$(usex upnp)
)